Installing and Getting Started with Defense Solutions

About Defense Solutions and this guide

Release notes

Installation and setup (includes system requirements)

Quick reference

MOLE tutorial

Developing with Defense Solutions
Contents

1 About Defense Solutions and this guide  1
   About this guide  2
   Overview of Defense Solutions applications  3
   Documentation  6
   Defense Solutions SDK  7
   Getting help  7

2 Release notes  9
   Version 10 for Windows and Linux  10
   Version 9.3.1 SP1 for Windows, Linux, and Solaris  11
   Version 9.3.1 for Windows, Linux, and Solaris  12
   Version 9.3 for Linux/Solaris  13
   Version 9.3 SP1 for Windows  13
   Version 9.3 for Windows  14

3 Installation and setup  19
   System requirements  20
   Installing Defense Solutions  22
   Starting and setting up Military Analyst  27
   Starting and setting up MOLE  28
   Creating geodatabases or importing/loading data  38

4 Quick reference  41
   Getting started geoprocessing with Defense Solutions  42
   Military Analyst quick reference  47
   MOLE quick reference  54
5 MOLE tutorial
   Exercise 1: Creating MOLE data using ArcCatalog  59
   Exercise 2: Working with force elements in ArcMap  72
   Exercise 3: Working with tactical graphics in ArcMap  79
   Exercise 4: Changing the 3D display type  83
   Exercise 5: Applying tracking to MOLE features  87

6 Developing with Defense Solutions  92
   Additional system requirements for developers  93
   What you get in the Defense Solutions SDK  93
   Migrating your Military Analyst and MOLE applications
to the Defense Solutions library  97

Index
About Defense Solutions and this guide

In This Chapter

• About this guide
• Overview of Defense Solutions applications
• Documentation
• Defense Solutions SDK
• Getting help

Defense Solutions 10 is a set of ESRI software applications and application programming interfaces (APIs) designed for the defense and intelligence communities. The set consists of:

• **ArcGIS Military Analyst**, an ArcGIS extension consisting of a suite of utilities and API designed to enhance the geospatial analysis capabilities of the defense/intelligence user community, specifically those who want to manage and exploit National Geospatial-Intelligence Agency (NGA) Raster Product Format (RPF) data, Vector Product Format (VPF) data, and Digital Terrain Elevation Data (DTED).

• **Military Overlay Editor (MOLE)**, a software application and API that combine military symbology standards with ArcGIS analysis capabilities so that you can enhance the effectiveness of your command and control (C2) and mission applications.
About this guide

This guide, which is part of the Defense Solutions documentation set, is intended to help get you up and running quickly with Defense Solutions.

It is divided into the following chapters:

- **Chapter 1: About Defense Solutions and this guide** gives an overview of Military Analyst and MOLE, provides conventions used in the Defense Solutions documentation, provides a list of what’s included in Defense Solutions, and explains how to get additional help or access additional Defense Solutions resources.

- **Chapter 2: Release notes** provides a list of what’s new, resolved issues, and known issues for this release.

- **Chapter 3: Installation and setup** provides a list of hardware and software requirements for Defense Solutions. It also provides step-by-step installation instructions, upgrading instructions, and tips for starting and setting up Defense Solutions in different environments, with different ESRI products, and for different uses.

- **Chapter 4: Quick reference** provides brief descriptions of the main user interface components of the Military Analyst and MOLE software applications.

- **Chapter 5: MOLE tutorial** steps you through MOLE tasks ranging from basic to complex using sample data. The tutorial sample data is installed with MOLE.

- **Chapter 6: Developing with Defense Solutions** helps jump start your development effort by providing key concepts, walk-throughs of common developer scenarios, and tips for using the samples and documentation.

The following is a list of conventions used in the Defense Solutions documentation.

- The step-by-step procedures reflect the Windows XP operating system using the Classic setting for the Start menu and Windows Explorer Folder Options. An effort is made to provide tips or procedures for other operating systems when the steps vary significantly from operating system to operating system.

- Variables are enclosed with the less-than and greater-than symbols. For example, `<ArcGIS installation directory>` is used to reference the directory to which you installed ArcGIS. By default, this directory is C:\Program Files. By default, Military Analyst and MOLE are installed to `<ArcGIS installation directory>/ArcGIS`.

- Back slashes (`\`) are used for Windows-specific directory paths. Forward slashes (`/`) are used for all other directory paths.

- The greater than symbol (`>`) denotes menu paths. For example, Start > Programs > ArcGIS > ArcMap is the menu path within the Start menu that opens ArcMap.

- “Click” instructs you to left-click the mouse once; “double-click” instructs you to left-click the mouse twice.

- “Press” is used for keyboard keys.

- **Boldface Courier New** font is used for text you type or sample code snippets.
About Defense Solutions and this guide

- The term “edit” is used for changes to MOLE graphics that require you to be in an edit session as well as for some changes that do not require you to be in an edit session.

- MOLE, MIL-STD-2525B Change 2, and APP-6A are primarily used in the context of war and the military—for creating wartime battlefield scenario maps. However, they are also used for communicating non-wartime activities and groups, such as defense and intelligence, weather conditions, supply quantities, and so on.

For simplicity, especially in topics geared toward new users, the term “military” is used as an umbrella term for items that aren’t necessarily exclusive to the military, such as intelligence groups and weather conditions. This usage allows for easy distinguishing between MOLE and ArcGIS functions.

For the same reason, “battlefield scenario” may be used to refer to “situational awareness map” or “common operational map.”

- In this getting started guide and in the MOLE context-sensitive help, cross references to topics in ArcGIS Desktop Help are in italic font. To quickly access the topic:

1. Open ArcGIS Desktop Help by selecting it from the Help menu in ArcMap, ArcCatalog, or ArcGlobe.
   Or click Start > Program Files > ArcGIS > ArcGIS Desktop Help > ArcGIS Desktop Help.
2. In the ArcGIS Desktop Help window, click the Search tab.
3. In the text box of the Search tab, type the italic phrase, then click the ask button.

In most cases, the cross-referenced topic will be the first topic listed in the search results. Otherwise, it will be within the top few topics listed.

Overview of Defense Solutions applications

ArcGIS Military Analyst

Military Analyst is an ArcGIS extension consisting of a suite of utilities and an API designed to enhance the geospatial analysis capabilities of the defense/intelligence user community, specifically those who want to manage and exploit National Geospatial-Intelligence Agency (NGA) Raster Product Format (RPF) data, Vector Product Format (VPF) data, and Digital Terrain Elevation Data (DTED). The functionality can be divided into these categories: data management, Coordinate tool, terrain analysis, geodesy, conversion, ArcGlobe functionality, and geoprocessing. Military Analyst tools are designed to be used separately or together, are fully functional out of the box, are Component Object Model (COM)-compliant, and are ideal for customization with ArcObjects.

With Military Analyst you can recursively load data into catalogs (simplify the loading process), and use the catalogs to manage how the data is displayed in ArcMap. With the Coordinate tool you can easily convert between different coordinate formats while working in a map document. The geodesy tools provide the capability to calculate and display linear distances and projected ellipses that are spatially accurate and geodetically correct in any projection and in any part of the world. The Convert VPF Features function allows you to convert VPF data, and the Convert Coordinates function allows you to convert all the coordinates in a file, whether contained in a field within a table or the geometry of a feature class. ArcGlobe functionality includes tools.
for threat dome generation and fly-through capabilities that allow you to view and analyze data on a 3D surface; the functionality also includes the Coordinate tool.

With the terrain analysis tools, you can mosaic rasters, find a highest or lowest point, calculate linear visibility between two points, compute radial visibility, and more. The key feature of the terrain analysis tools is that they are compatible with Military Analyst DTED catalogs, enabling cross-tile surface analysis with no required merging or geoprocessing.

The geoprocessing tools allow you to perform many of the Military Analyst capabilities in the geoprocessing framework and provide tools for converting OILSTOCK data to shapefiles and for converting table data into different geometries.

The Military Analyst product includes the following items:

- User interface tools and commands—For an introduction to the main tools and commands, see chapter 4, *Quick reference*.
- Geoprocessing tools—For a complete listing and instructions on how to access, see chapter 4, *Quick reference*.
- A documentation set—Described in this chapter.
- An API—Described in chapter 6, *Developing with Defense Solutions*.

**MOLE**

MOLE is a software application and API that combine military symbology standards with ArcGIS analysis capabilities so that you can enhance the effectiveness of your command and control (C2) and mission applications. MOLE is in strict adherence to the MIL-STD-2525B Change 2 and APP-6A military symbology specifications. It supports all appendices of both specifications. It also allows you to depart from the specifications if you choose.

MOLE’s out-of-the-box functionality allows you to:

- Use existing databases, shapefiles, or tabular data
- Symbolize data from tracking information using the ArcGIS Tracking Analyst extension and ArcGIS Tracking Server
- Use rules to group symbols for improved map readability or to speed up your tasks
- Use the MOLE Symbol Editor to preview how the symbol you are constructing will look as you change values in the 15-character Symbol ID code or attribute fields or choose different military elements to symbolize
- Provide lifelike views of battlefield scenarios using MOLE in ArcGlobe, as illustrated in the following image.

To use MOLE, your data must be in a geodatabase or shapefile. There are many ways you can use your existing data or create new data to populate a geodatabase for use with MOLE. For more information, see *Creating geodatabases or importing/loading data* in *Installing Defense Solutions* in chapter 3 of this guide.
To use MOLE in ESRI applications such as ArcMap and ArcGlobe, you must use MOLE-specific commands and tools on it. For example, to add MOLE data to a map, you use the Add MOLE Data toolbar button instead of the ArcGIS Add Data button. To identify a feature, you use the MOLE Identify button instead of the ArcGIS Identify button.

The MOLE product includes the following items:

- User interface tools and commands—For an introduction to the main tools and commands, see chapter 4, *Quick reference*.
- Geoprocessing tools—For a complete listing and instructions on how to access, see chapter 4, *Quick reference*.
- A documentation set—Described in this chapter.
- An API—Described in chapter 6, *Developing with Defense Solutions*.
- Sample data—Described in the following section.

**Sample data**

MOLE sample data is installed to the `<ArcGIS installation directory>/ArcGIS/MOLE/ Tutorial directory`. This directory includes sample databases, sample shapefiles, sample .mxd files, and sample data to use with ArcGIS Tracking Analyst functionality.

MOLE also comes with sample data and applications to help jump start your development tasks. These are described in the *Defense Solutions SDK* section of this chapter.
Documentation

Military Analyst and MOLE each come with a documentation set that is installed automatically when you install either product. The documentation set, described in detail below, includes this *Installing and Getting Started with Defense Solutions* guide, help topics within ArcGIS Desktop Help (including geoprocessing help) and ArcGIS Web Help, and context-sensitive help.

- *Installing and Getting Started with Defense Solutions*—This guide provides a basic overview of MOLE and Military Analyst tools, start-up assistance, a quick reference, and a tutorial for MOLE.

- *ArcGIS Desktop Help*—The ArcGIS Desktop Help describes every tool and command in Military Analyst and MOLE and provides context for them. It contains a comprehensive index and allows you to perform natural language searches, full-text searches, and in-topic searches. The ArcGIS Desktop Help is automatically installed when you install any license level of ArcGIS. To access the ArcGIS Desktop Help from ArcMap, ArcCatalog, or ArcGlobe, click Help > ArcGIS Desktop Help. A help window displays. In the left pane (table of contents pane) of the help window, navigate to Extensions > Military Analyst or Extensions > Military Overlay Editor.

  You can also access ArcGIS Desktop Help by clicking Start > ArcGIS > ArcGIS Desktop Help.

- Context-sensitive help in ArcMap and ArcGlobe—This help can be accessed from any Military Analyst or MOLE user interface item by clicking the question mark image ![question mark](image) in the title bar of the dialog box.

- Help for Military Analyst and MOLE geoprocessing tools. You can access this help from within:
  - The *ArcGIS Desktop Help* window. In the table of contents, you can view the topics by navigating to Geoprocessing tool reference, then either Military Analyst toolbox or Military Overlay Editor toolbox.
  - The geoprocessing tool you have open. Dynamic help is provided in each tool’s window. To access this help, click the Show Help button in the tool’s window. A right panel opens, displaying help content. As you click in different fields in the tool’s window, you will see the help content change to reflect the field. For information on accessing Military Analyst or MOLE geoprocessing tools, see chapter 4, *Quick reference*.

- *ArcGIS Web Help*—You can access the help system online at [http://webhelp.esri.com](http://webhelp.esri.com). Like the ArcGIS Desktop Help, this version of the help contains both Military Analyst and MOLE documentation. It is fully searchable and printable and contains the most current information available. It includes geoprocessing help.

Military Analyst and MOLE also come with developer documentation, as described in the following section.
Defense Solutions SDK

The Defense Solutions SDK consists of:

- The Military Analyst API and MOLE API—include object libraries, Java jars, and C++ header files. Starting at 9.3 SP1 for Windows and 9.3 for Linux/Solaris, these APIs are available through the Defense Solutions library. This library combines two distinct libraries from previous releases of ArcGIS—the Military Analyst library and the MOLE library. See chapter 6 for information about how to update existing Military Analyst and MOLE applications to use the new Defense Solutions library.

- Samples—including fully documented standalone application samples and code snippets.

- Developer documentation—including a library overview, library reference, and articles that provide conceptual information and context. It also includes documentation that describes how to use the samples.

Using the SDK, you can build applications that perform such tasks as:

- Convert coordinates to military formats
- Create geodetically correct geometries
- Provide other defense analysis tools
- Provide military symbology in maps

The Defense Solutions SDK supports development in the following programming languages and platforms:

- Windows: C#, Visual Basic .NET, Java, and Visual C++
- Linux: cross-platform C++, and Java

To jump start your Military Analyst and MOLE development tasks, see chapter 6 of this guide.

Getting help

In addition to the comprehensive documentation set described in this chapter, you can use ESRI online support resources or you can call ESRI technical support. ESRI also provides several Defense Solutions training courses.

Online support

The ESRI support Web site, http://support.esri.com, contains product announcements, technical papers, white papers, knowledge base articles, downloads, system requirements, discussion forums, a Web version of the latest Defense Solutions help systems, and much more.

- For forums for Military Analyst and MOLE, see http://forums.esri.com/forums.asp?c=5.
- For updated information about this release, see knowledge base article number 35254 on the support site, http://support.esri.com.
Installing and Getting Started with Defense Solutions

- For the Military Analyst and MOLE download page, see http://www.esri.com/software/arcgis/defense-solutions/index.html.

Technical support

Technical support for users within the United States is available through e-mail at support@esri.com or telephone toll free at 888-377-4575 and local at 909-793-3774. Technical support for international users is provided by your local ESRI distributor. A directory of distributors can be found at http://gis.esri.com/intldist/contact.

For more information, see Contacting Technical Support in the Getting started > Getting more help section of the ArcGIS Desktop Help system.

Training

ESRI provides an instructor-led Defense Solutions developer training course in addition to educational opportunities related to geographic information science, GIS applications, and GIS technology. You can choose from among traditional instructor-led courses, virtual classroom instructor-led courses, Web-based courses, and self-study workbooks. To find education solutions that fit your learning style, visit http://training.esri.com/gateway/index.cfm.
In This Chapter

- Version 10 for Windows and Linux
- Version 9.3.1 SP1 for Windows, Linux, and Solaris
- Version 9.3.1 for Windows, Linux, and Solaris
- Version 9.3 for Linux/Solaris
- Version 9.3 SP1 for Windows
- Version 9.3 for Windows

This chapter provides a list of what’s new in the 10 and 9.3x releases of Defense Solutions.

Developments that have occurred too late to be included in this chapter are reported in knowledge base article 35254, *Late-breaking release information for Defense Solutions* in the ESRI Knowledge Base at [http://support.esri.com](http://support.esri.com).
Version 10 for Windows and Linux

Some tasks you perform in Military Analyst and MOLE can now be performed directly in ArcGIS, using native ArcGIS functionality, which means:

- You no longer need to download and install separate applications to get the same capabilities.
- You no longer need to learn separate applications to accomplish tasks; you only need to know ArcGIS.

For a table that describes the new (version 10) way you can do tasks that you did in Military Analyst and MOLE prior to version 10, see the Migrating from Military Analyst and MOLE topic, which is linked to from the Getting started with defense in ArcGIS topic at:

Military Analyst issues addressed

- (NIM050325) Addressed problem with empty cell values and the Convert Coordinate tool. With this fix, when the tool encounters empty cell values, it skips them.

MOLE issues addressed

- (NIM052048 ) The MOLE marker symbols for point tactical graphics do not render text modifier text. It is the same code for MOLE lines and fill symbols.
- (NIM053712) A MOLE text modifier displays as black instead of using the affiliation color when not using fill.
- (NIM053726) Some MOLE symbols display internal icons as black instead of using affiliation color when not using fill.
- (NIM055759) Fixed the symbol for dummy minefield; it now displays the H and N modifiers listed in 2525B Change 2.
- (NIM052213) Headquarters and/or Task Force modifiers only display with certain affiliations for MOLE MOOTW symbols.
- (NIM057226) MOLE line tactical graphic Infiltration Lane (‘G*G*OLI--****X’) renders incorrectly.
- (NIM057226) Memory leak on zoom with certain tactical graphics.
- (NIM053499) A MOLE tactical graphic displays incorrectly when edited within a rotated frame.
• (NIM052816) MOLE tactical graphic boundary symbols are misplaced.

• (NIM053115) When reference scale is set in a map document, the size of the labels follow the reference scale instead of the force element symbols.

• (NIM054225) Adding MOLE graphics to ArcGlobe and then refreshing or panning in/zooming repeatedly causes a memory leak that crashes ArcGlobe.

• (NIM033447) Addressed editing issues in the MOLE Symbol Editor with APP-6A force element graphic layers.

Version 9.3.1 SP1 for Windows, Linux, and Solaris

Military Analyst Issues addressed:

• (NIM045675, NIM043110) An issue with using the GeoSymRenderer on Linux and Solaris has been fixed.

• (NIM038360, NIM046887) Issues with the calculation of geodesic rhumb lines at certain longitudes has been addressed.

• (NIM035959) An issue when canceling the Load MA Catalog geoprocessing tool while loading raster datasets has been addressed.

• (NIM043172) An issue when using the Radial Line of Sight geoprocessing tool/script with datasets with World Azimuthal Equidistant projection has been fixed.

• (NIM046325) Disabled the unsupported Use Uniform Renderer option in ArcGlobe.

MOLE Issues addressed:

• The MCM Drone symbol from MIL-STD 2525B Change 1 is now supported.

• (NIM040273) The ForceElementLayer API item symbolized graphics using the display height value when it was loading a layer with SizeIsRatio. This issue has been addressed.

• (NIM039780, NIM013347) Several symbology label display issues in ArcGlobe have been addressed.

• (NIM043248, NIM042105, NIM043453) Symbology display issues related to the use of custom symbol styles have been fixed.

• (NIM046052, NIM046586) Symbology display issues encountered when switching between coordinate systems projections have been addressed.

• (NIM039925) An issue that sometimes prevented ArcGIS Engine GlobeControl applications from loading ArcGlobe documents (.3dd files) containing MOLE data has been fixed.

• (NIM044667) The last segment of some tactical graphics disappeared when the layer symbol size was set to a large value. This issue has been fixed.

• (NIM046337) An issue in ArcGlobe where draped symbols did not appear north of the 45th latitude has been addressed.

• (NIM040925) When metadata specifying the military specification type was
absent, improper symbology display would result. This issue has been fixed.

• (NIM041631) An issue that caused problems in SysAllocString called from RenderHelper::DecodeMessageString during MOLE rendering has been fixed.

Version 9.3.1 for Windows, Linux, and Solaris

This release replaces the previous release, which was a compatibility release for ArcGIS 9.3.1 and was named the release “for ArcGIS 9.3.1 users.” This newer release contains fixes the compatibility release does not; these fixes are listed below.

Install this 9.3.1 version if you are using ArcGIS 9.3.1. If you are using ArcGIS 9.3, install the 9.3 version of Military Analyst and/or MOLE and the latest service pack (SP) available for 9.3 Military Analyst and MOLE.

Military Analyst  Issues addressed:

• All issues addressed by the Military Analyst 9.3 SP1 Edit Patch and the Military Analyst 9.3 SP1 releases. For the lists of issues addressed in these releases, see the ESRI Patches and Service Packs page.

• (NIM042306) An issue with RPF layer visibility when the layer is published as an WMS service has been addressed.

• (NIM044175) An issue with editing data with an RPF layer in the map has been addressed.

• (NIM045096) An issue in which running the Analyze tool on Military Analyst catalogs would close ArcMap has been addressed.

• (NIM040477) Fixed an issue in which the Threat Dome tool mistakenly allowed you to choose a Web service as the data source.

MOLE  Issues addressed:

• All issues addressed by the MOLE 9.3 SP1 release. For the lists of issues addressed in MOLE 9.3 SP1, see the ESRI Patches and Service Packs page.

• (NIM038512, NIM038514) An issue with updating while calling ICachedGraphicLayer.Refresh() has been addressed.

• (NIM039780) An issue with tactical graphics not labeling in ArcGlobe has been addressed.

• (NIM038150, NIM038543, NIM039621) A symbology issue with UTM coordinate systems projection has been addressed.

• (NIM037237, NIM037239, NIM038315, NIM040113) Issues with using IMOLESymbol in dynamic display have been addressed.

• (NIM033460, NIM034620, NIM036371, NIM038312, NIM038603, NIM038607, NIM038658, NIM038687, NIM038755, NIM039178, NIM039984, NIM040215, NIM040740, NIM040902, NIM041501, NIM041800, NIM042278, NIM042911, NIM043225) Issues with symbology and label display have been addressed. Several fixes brought MOLE symbols in tighter alignment with military specifications.
(NIM044643) Issues with MOLE custom callbacks using in-memory workspaces have been addressed.

(NIM043819) Minefield tactical graphics displayed incorrectly when the user was logged on with a Limited User Account. This issue has been addressed.

Version 9.3 for Linux/Solaris

The issues that have been addressed for this release include the following:

**Military Analyst**

- (NIM037093) The Geodesy Graphic tool interfered with the proper functioning of ArcMap when the tool was used in a map document whose data frame was set to a polar projection. This issue was resolved.

**MOLE**

- (NIM034153) A ClassCastException was generated by calling cachedGraphic.ICachedGraphic.getGeometry. This issue was resolved.

- (NIM032961) Minefields were not being drawn correctly with MOLE; more specifically, mine symbols were not being drawn properly inside their areas. This problem has been fixed.

- (NIM032960) Wire obstacles were not drawing correctly with MOLE. This problem has been fixed.

Version 9.3 SP1 for Windows

The issues that have been addressed for this service pack include the following:

**Military Analyst**

- A new tool, Highest/Lowest Point by Polygon, has been added to the Military Analyst Terrain Analysis toolset. Given a polygon featureclass as input, the tool finds the highest or lowest point within each polygon.

- When a specified elevation data layer was used in combination with the Threat Dome tool, ArcGlobe closed. This issue has been resolved.

- (NIM037093) The Geodesy Graphic tool interfered with the proper functioning of ArcMap when the tool was used in a map document whose data frame was set to a polar projection. This issue was resolved.

- (NIM035959) The execution of the Load MA Catalog tool could not be stopped by pressing Escape or the Cancel button in the Tool Message Box. This issue was resolved.

- (NIM035086) A ClassCastException was generated when IGeometry was cast to IGeoEllipse. This issue was resolved.

- An extraneous field (SPOT) was removed from the fields listed as required input for two geoprocessing tools, Linear Line of Sight From Features and Create Observers From Table.

- The help has been revised to reflect the removal of five parameters from the Convert Coordinates in File (CCIF) geoprocessing tool. In addition, a command
line example and script have been added to the help documentation for the CCIF geoprocessing tool.

- Documentation for Mosaic Raster Catalogs and the Path Slope geoprocessing tool has been improved.
- Context-sensitive help has been provided for tools on the Military Analyst toolbar.
- Help has been supplied or finalized for the geoprocessing tools below:
  - Analysis > Link > Shortest Path
  - Data Management > Extract RPF Catalog Items
  - Utilities > Convert Coordinates in File geoprocessing tools
  - Analysis > Link > Create Links

**MOLE**

- An issue connected with the implementation of point tactical graphics using symbol-based functionality has been addressed.
- (NIM034448) Saved changes to leader positions are now displayed in the relevant map document when PLTS Defense is installed.
- An issue that prevented the Move Leaders tool from changing leader positions has been resolved.
- (NIM039134) An issue associated with scaling and sizing tactical graphic point symbols has been resolved.
- (NIM03776) The color of MOLE graphics changed after the display was refreshed. This issue was resolved.
- (NIM036534) There was a memory read error when a Globe control was used with MOLE data. This issue was resolved.
- (NIM036873) Tactical areas changed color when 2D and 3D maps were refreshed. This issue was resolved.
- (NIM034153) A ClassCastException was generated by calling cachedGraphic.ICachedGraphic.getGeometry. This issue was resolved.

**Version 9.3 for Windows**

**General**

The following notes apply to both Military Analyst and MOLE.

- The getting started guides (.pdf files) and readme files for Military Analyst and MOLE were combined into one getting started guide, the *Installing and Getting Started with Defense Solutions* .pdf file. This .pdf file is at the top level of both the Military Analyst and MOLE .zip files that you can download. It is also installed to <ArcGIS installation directory>/ArcGIS/Documentation/install_and_get_started_defense.pdf when you install Military Analyst or MOLE.
• On Vista, you must enable context-sensitive help. The first time you use What’s This? context-sensitive help, the Windows Help and Support window appears.

In the Windows Help and Support window, click Windows Help program (the blue text in the body of the text).

A Web page opens that lets you download an application that allows you to enable context-sensitive help. Follow the on-screen instructions.

• If you have installed Acrobat 8.0, you may encounter broken links when you click links from ArcGIS Desktop Help topics to .pdf files. This may be the result of having Adobe Reader 8.0 installed on the same machine. You should be able to fix this link issue by uninstalling Reader 8.0, then installing any other version of Reader, such as Reader 7.0. (You may prefer not to install any version of Reader and instead use Acrobat 8.0 to view the .pdf files.)

Developers

• The new Defense Solutions library, esriDefenseSolutions.olb, merged two distinct libraries from previous releases of ArcGIS—the Military Analyst library (esriMilitaryAnalyst) and the MOLE library (esriMOLE.olb). As a result, you may need to make some changes to your existing ArcObjects applications, as described in Migrating your Military Analyst and MOLE applications to the Defense Solutions library in chapter 6 of this guide. The Defense Solutions Java software development kit (SDK) is integrated with the ArcGIS SDK.

• The ESRI SDK or SDKs you intend to use must be installed before Military Analyst and/or MOLE is installed. This applies to both Desktop SDKs (VC++) and Engine SDKs VC++, .NET, cross-platform C++ on Windows or UNIX).

The following new toolbar buttons were added to the Military Analyst toolbar:

- **Hide Selection**—Allows you to hide all features that were not selected using the Match Selection tool.

- **Match Selection**—Allows you to search a table to find fields that match a feature that you’ve clicked on or selected in a table.

- **Restore Selection**—Allows you to redisplay features that were hidden with the Hide Selection tool.
WebLinks—Allows you to define dynamic Uniform Resource Locators (URLs) that will be created using fields from a selected feature. These URLs will be executed to display Web pages containing information relevant to the selected feature. The Web Links tool is designed to do Web searches based on a selected feature’s attribute. You first build a Web search template based on an attribute field in a feature class, then use the tool to select a feature; a Web search will be performed based on the attribute value of that feature.

The following became available as geoprocessing tools. For information on how to access geoprocessing tools and their documentation, see chapter 4, Quick reference.

- A new toolset, Terrain Analysis, was added to the Analysis toolset in the Military Analyst toolbox. It contains the following new tools:
  - Highest/Lowest Point by Extent—Finds the highest or lowest points for a surface within a defined extent.
  - Hillshade—Creates a shaded-relief raster of the input surface based on a light source.
  - Linear Line of Sight—Determines the visibility, based on the elevation, of all the points in a straight line on a surface between a specified observer and target points and generates a line shapefile to display this information.
  - Linear Line of Sight From Features—Builds a 3D polyline of visible and invisible paths between the observer points and target points as well as a point feature class of obstructions.
  - Path Slope—Finds the slope of the segments of an input polyline path that exists over a surface.
  - Radial Line of Sight—Determines what region of a surface may be seen from input observers.
  - Z-Factor Tool—For geographic datasets, this tool determines the z-factor for scaling z-units into xy-units. The z-factor is based on the middle latitude of the dataset.

For some of the terrain analysis tools, such as Linear Line of Sight, the Military Analyst symbolization may not fully display; for example, you may not see the default red/green colors for visible/invisible, respectively.

For many of the Military Analyst geoprocessing tools, you cannot drag and drop a layer in the ArcMap table of contents into the tool’s input field. You must instead use the browse button to navigate to the layer or type in the file path and layer name.

- A new toolset, Link Tools, has been added to the Analysis toolset. It contains the following new tools:
  - Create Links—Creates a line feature class that links points in a feature class based on from- and to-attributes in a separate table.
  - Find Shortest Path & Critical Links—Computes the shortest path and any critical links between selected points. A critical link is a link that can be completely isolated from the network by severing it at one endpoint.
  - Recalculate Links—Updates the geometry of a line feature class from its topological attributes and a point feature class. This tool is intended to run on
a feature class that was produced by the Create Links tool. Run this tool when
the point locations have changed since you generated links from them.

• A new tool, Convert Coordinates in File, has been added to the Utilities toolset. It
converts coordinates in a point feature class or a table to and from the following:
  - Point features
  - Decimal degrees (DD)
  - Degrees-minutes-seconds (DMS)
  - Universal Transverse Mercator (UTM)
  - Military Grid Reference System (MGRS)
  - United States National Grid (USNG)

• A new tool, Extract RPF Catalog Items, has been added to the Data Management
  toolset. It lets you extract RPF tiles from a Military Analyst catalog by specifying
  corner coordinates and other options.

• A new toolset, Samples, provides sample scripts for creating and loading DTED
catalogs, RPF catalogs, and VPF catalogs. It also provides a script for loading
non-RPF data.

The 3D Viewer is no longer available (its button has been removed from the toolbar).
Its functionality has been moved to ArcGlobe.

Developers

**New coordinate conversion API.** This API allows you to convert coordinates
(between DD, DMS, UTM, MGRS, and USNG), set precision for your output
coordinates, parse input coordinates, and format output coordinates. If you want to
convert coordinate formats other than DD, DMS, UTM, MGRS, and USNG, you can
develop a custom converter and plug it into the coordinate conversion API. You can
also specify ArcGIS coordinate systems and transformations.

• MOLE now supports MIL-STD-2525B Change 2 and the following APP-6A
  symbols: antitank obstacles, tetrahedrons, dragon’s teeth, and other similar
  obstacles (2.X.2.1.3.3).

To use the new APP-6A symbols, assign them the corresponding Symbol ID code
just as you would other symbols (in this case, G*C*BOATD-****). You can use
the EType field to specify the movable attribute:

F—Fixed and prefabricated
M—Movable
P—Movable and prefabricated

• A new text box, Symbol Height, was added to the Renderers tab on the Layer
Properties dialog box (tactical graphics only). It lets you change graphic height
for all tactical graphics in a layer. For more information, see the Enabling tactical
graphic renderers topic in ArcGIS Desktop Help.

• A new drop-down menu, Direction Visibility, was added to the Fields tab of the
force element Layer Properties dialog box. It lets you map a field in your data
to a field name MOLE uses to determine whether or not to display the graphic’s
direction of movement indicator. For valid values for the field, see Attribute data
field descriptions in ArcGIS Desktop Help.

- The name of the menu item MOLE > Update Older MOLE Database changed to MOLE > Update pre-9.0 MOLE Database. It functions the same way as it did at 9.2; it updates pre-9.0 MOLE databases.

- All center point modifiers began to display in the preview window of the MOLE Symbol Editor.

- Several changes were made to improve performance, including a change that speeds up the loading of MOLE layers in ArcGIS applications such as ArcMap and ArcGlobe.

- Changes were made to the moleCore database, so if you’ve customized moleCore, be sure to save a backup before you install this service pack. Note that customizing moleCore is not recommended.

- When you want to change a value for a property in the Rule Properties area on the Leadering tab of the MOLE Layer Properties dialog box, you no longer have to left-click and drag over the Value column’s text box. The text box now functions like any standard text box.

- In some cases on Windows, when you extruded FLOT lines in ArcGlobe, ArcGlobe would unexpectedly stop responding. This problem was fixed.

- In some cases, after performing a UTM projection on an incoming geometry, MOLE was not checking to see if the projected shape was valid or was instead empty. In cases where the incoming geometry was outside the coordinate system of the display, the projected function was returning an empty geometry, which caused unpredictable results when MOLE tried to use that empty geometry to construct a graphic. This problem was addressed.

Developers

- Developers can now use standard ArcGIS cartographic and display ArcObjects to display and work with MOLE symbols on a map. This is referred to as the symbol-based approach for creating MOLE graphics.

  The symbol-based approach lets you develop functionality that lets your users bypass the MOLE toolbar and, in some cases, the MOLE Layer Properties dialog boxes. Additional advantages and a comparison of the approaches is provided in the Defense Solutions library overview in the developer documentation.

  The symbol-based approach is a good approach to use if you need to render military symbols quickly on a map and all you have is the 15-character Symbol ID codes. However, it has limitations that are not present in the traditional approach, the feature-based approach. For example, the symbol-based approach does not let you perform complex queries on the data and limits your ability to customize the display.

- Changes were made to improve performance, such as a change made to speed up the loading of FEGraphicFactory.

- (NIM009615) Some ArcGIS Engine applications that ran continuously for several days in a row and performed frequent MOLE feature updates (made frequent calls to ICachedGraphicLayer.Refresh) experienced problems. This problem was addressed.
In This Chapter

- System requirements
- Installing Defense Solutions
- Starting and setting up Military Analyst
- Starting and setting up MOLE
- Creating geodatabases and importing/loading data

This chapter provides system requirements and instructions and tips for installing, uninstalling, and setting up and starting ArcGIS Military Analyst and MOLE.
System requirements

You must have licensed an ESRI software application that comes with an Engine runtime, such as ArcGIS Desktop (ArcView, ArcEditor, or ArcInfo) or else have ArcReader or ArcGIS Server.

- ArcGIS Desktop (ArcView, ArcEditor, or ArcInfo)—required if you want to use the out-of-the-box Military Analyst or MOLE software applications or if you intend to customize out-of-the-box functionality using the ArcGIS Desktop SDK.

- ArcEngine—required if you want to build Military Analyst or MOLE applications from the ground up and deploy them as standalone or client applications.

- ArcReader—required if you want to view Military Analyst or MOLE maps in ArcReader.

If you’re not sure which products you’re licensed for, you can find out at http://service.esri.com.

In ArcGIS Desktop, the Military Analyst or MOLE functionality you can use is dependent on which level of licensing (ArcView, ArcEditor, ArcInfo) you choose. For example, with an ArcView license, you cannot perform advanced editing functions or use some geoprocessing functions.

Your system must meet the same system requirements listed for the ESRI application(s) with which you intend to use it. In general, Military Analyst and MOLE support Windows and Linux across ESRI applications. Your system must also meet some additional requirements. Use the following procedure to check that your system meets all applicable requirements.

1. In your Web browser, go to http://resources.arcgis.com.

2. Under ArcGIS Products, click the product you plan to use.

   On the resulting page, in most cases, a System Requirements link appears in the left pane of the page.

3. Click the System Requirements link and review the displayed system requirements.

4. Test that your base application(s) is working (for example, ArcGIS Desktop) by starting the application and viewing sample data.

5. Review the following additional requirements:

   - Adobe Reader 5.0 or higher is required for viewing the portion of Defense Solutions documentation provided in Adobe Portable Document Format (PDF). You can download this free reader from http://www.adobe.com/products/acrobat/readstep2.html.

   - If you intend to use Defense Solutions with ArcGlobe, you must have the ArcGIS 3D Analyst extension installed. For information, see Installing Defense Solutions in this chapter.

   - If you intend to use tracking functionality on Defense Solutions features, you must have the ArcGIS Tracking Analyst extension installed. A tutorial to help you get started with tracking in MOLE is provided in chapter 5, MOLE tutorial.
• ArcGIS Spatial Analyst and ArcGIS 3D Analyst are required for the use of many of the terrain analysis and ArcGlobe tools in Military Analyst. For details, see Military Analyst notes in this section.

**Military Analyst notes**

Many of the terrain analysis and ArGlobe tools require that you have ArcGIS Spatial Analyst and ArcGIS 3D Analyst installed. The following table shows the extension requirements necessary to use Military Analyst tools:

<table>
<thead>
<tr>
<th>Feature</th>
<th>Spatial Analyst required</th>
<th>3D Analyst required</th>
<th>Spatial or 3D Analyst required</th>
<th>MA Catalog functional</th>
<th>Raster dataset functional</th>
</tr>
</thead>
<tbody>
<tr>
<td>Mosaic</td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>RLOS</td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>LLOS</td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>Hillshade command</td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>Highest point</td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>Lowest point</td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>Extract tool</td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>Hillshade tool</td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
</tbody>
</table>

**MOLE notes**

If you have an ArcView license, you cannot use the New Feature Class wizard in ArcCatalog to create MOLE feature classes (because they are custom ArcGIS objects), perform advanced editing functions, or use some geoprocessing tool functions. However, you can create a non-MOLE feature class, that is, an ArcGIS point, line, or polygon feature class, and then use the Add MOLE Fields Single geoprocessing tool on it to create a MOLE feature class.
Installing Defense Solutions

This section provides detailed instructions for installing Defense Solutions:

- Pre-installation checklist
- Installing Military Analyst and MOLE using a wizard
- Installing Defense Solutions silently
- Installing from a network and using managed setups
- Uninstalling Defense Solutions or modifying your installation
- Installing ArcGlobe
- Administrator privileges

Before you install using any of the installation procedures in this section, be sure to do the following:

- If you plan to use an SDK for Desktop or for Engine, make sure you install the SDK before installing Military Analyst or MOLE.

- Uninstall any previous versions of the Defense Solutions application (ArcGIS Military Analyst or MOLE) you intend to install. For example, if you are about to install MOLE, be sure to first uninstall any previous versions of MOLE, including beta versions.

- Ensure you have system administrator privileges on the machine on which you will install the Defense Solution application.

- If you are installing on Linux, you must not be the root user and you must be logged in as the same user who installed the ESRI application with which you intend to use Military Analyst or MOLE.

- Make sure your machine meets the system requirements listed in this chapter.

This procedure, applicable to Windows and Linux, describes how to install Military Analyst and MOLE using the installation wizard.

1. Download the Military Analyst or MOLE application per the instructions on the download page or your cover letter or e-mail. Or, if you received a CD, insert it into your CD drive.

   If you downloaded the application, unzip it to a local directory. If your operating system doesn’t have a zip (compression) utility, you must acquire one to unzip the Military Analyst or MOLE .zip file.

2. If you’re installing on a Linux system, as a root user, open the ArcGIS directory to which you intend to install Military Analyst or MOLE, then change ownership of that directory to a new user. Next, open that directory as the new user (do not install Military Analyst or MOLE as the root user) and run setup.exe against the ArcGIS directory.
3. Close all applications; it is recommended you print this *Installing Defense Solutions* section so that you can follow along the remaining steps as you install.

4. **Windows:** Navigate to where you unzipped the Military Analyst or MOLE application and double-click setup.exe. Or, if you are installing from a CD, navigate to the Military Analyst or MOLE directory on the CD and double-click setup.exe.

   **Linux:** Start the Military Analyst or MOLE installation by running ./Setup from the terminal.

   The Military Analyst or MOLE wizard begins, and its first panel appears.

5. Follow the instructions in the installation wizard until you get to the Select Features panel.

6. In the Select Features panel, select the features you want to install.

   The installation of your ESRI base application determines your installation location. The installation wizard does not permit you to browse to a different installation location.

7. Click Next, then, in the Ready to Install the Application panel, click Next. A status bar indicates the progress.

8. After Military Analyst or MOLE has been installed, the final panel of the wizard appears. Click Finish to close the wizard.

   Military Analyst or MOLE is installed on the machine. If you installed on a Linux system, ArcGIS Engine and MainWin are automatically installed with Military Analyst or MOLE.

### Next steps

- In order to have access to all of the Military Analyst and MOLE functionality, your RPF, VPF, DTED, and MOLE data must be in a geodatabase. For information, see *Creating geodatabases and importing data* in this chapter.

- If you are new to MOLE, step through the MOLE tutorial in chapter 5 of this guide.

- If you intend to program with the Military Analyst or MOLE APIs, use chapter 6 of this guide to help jump start your development work.
Installing and Getting Started with Defense Solutions

Installing Military Analyst and MOLE silently

This procedure describes how to bypass the installation wizard while installing Military Analyst and MOLE on Windows.

On Windows, you can use msiexec command line syntax to install without having to step through the installation wizard panels. To open the command line, click Start > Programs > Accessories > Command Prompt.

Syntax to perform a typical installation of either Military Analyst or MOLE silently:

```cmd
msiexec /i <path to setup.msi file>\setup.msi /qn
```

Syntax to perform a complete installation of Military Analyst or MOLE silently:

```cmd
msiexec /i <path to setup.msi file>\setup.msi /qn ADDLOCAL=ALL
```

ArcGIS Desktop (and therefore Military Analyst and MOLE) can be installed in accordance with Microsoft Group Policy procedures, a software deployment management method that allows administrators to provide software to users or computers in accordance with their needs without physically visiting each machine. For further information, see the deploying managed ArcGIS setups document at http://resources.arcgis.com/content/white-papers?fa=viewPaper&PID=67&MetaID=1625.

Installing from a network and using managed setups

After ArcGIS Military Analyst or MOLE is installed, you can use this procedure at any time to open the application’s installation program (setup.exe or setup.msi) to change the features you want installed or to uninstall the applications using a wizard.

Don’t uninstall your base ESRI application before uninstalling a Defense Solution application; always uninstall Military Analyst or MOLE first.

Windows

1. Click Start > Settings > Control Panel > Add/Remove Programs, then click ArcGIS Military Analyst or ArcGIS Military Overlay Editor to highlight it.
2. Click Remove.

   Follow the on-screen instructions to remove the application you selected.

   You can also uninstall Military Analyst or MOLE silently by typing the following syntax at the command prompt:

   ```cmd
   msiexec /x {GUID} /qn
   ```

   where GUID is a globally unique identifier, which can differ from version to version for a product.

   For Military Analyst 10, the GUID is
   `{F49A4424-6F2D-460A-952E-F97BC42110D7}`

   For MOLE 10, the GUID is
   `{908504CA-6843-40FF-BDD7-DBC49FB045B3}`

   For Military Analyst 9.3.1 SP1, and 9.3.1, the GUID is
   `{98197056-EF31-496C-8418-E3B3C758DCDF}`

   For MOLE 9.3.1 SP1, and 9.3.1, the GUID is

Uninstalling Defense Solutions or modifying your installation
Installation and setup

For Military Analyst 9.3 SP 1 and 9.3, the GUID is
\{670308FE-9847-4427-BA7C-D3EDB43A70D6\}

For MOLE 9.3 SP 1 and 9.3, the GUID is
\{5B70E4A8-059A-4E92-BDC8-E953D90EB808\}

For Grid Manager 9.3, the GUID is
\{623F6A7F-9913-408D-B179-800EF0E1EAA8\}

**Linux:**

At arcgis home, type:

```
./militaryanalyst10.0/uninstallMilitaryAnalyst
```

or

```
./mole10.0/uninstallMole
```

To use Military Analyst and MOLE in ArcGlobe, you must install the 3D Analyst extension.

1. Click Start > Control Panel.
2. In the Control Panel window, double-click Add or Remove Programs.
3. In the Add or Remove Programs window, click ArcGIS Desktop and click Change.
   The ArcGIS installation wizard appears.
4. In the first panel of the wizard, click Modify, then click Next.
5. In the second panel, in the list area, open the Extensions tree branch.
6. Click 3D Analyst, then click Next.
   The installation wizard installs 3D Analyst.
7. When the wizard indicates the installation is finished, click Finish.

ArcGlobe and ArcScene are now available from the Start menu. You may have to first activate 3D Analyst by opening ArcMap, then clicking Tools > Extensions.

To turn on the Military Analyst or MOLE toolbar in ArcGlobe, start ArcGlobe by clicking Start > Programs > ArcGIS > ArcGlobe. Then, right-click any ArcGlobe toolbar and click either Military Analyst or MOLE.
1. Administrator privileges are not required for a single-use license. All others see step 2.

2. If one or more of your users will not have administrator privileges on the computer(s) running Military Analyst or MOLE, you can give them permission to use all Military Analyst and MOLE functions by starting the installation manually (using the command prompt) and specifying an ADDLOCAL setting on the command line as follows:

   msiexec.exe /i <path to setup program>\<name> /qn ADDLOCAL=ALL

where:

   <path to setup program> is the file path to setup.msi if you’re installing a major release of MOLE, or to an .msp file if you’re installing a MOLE service pack.

   <name> is the name of the MOLE installation program (setup.msi for major releases; .msp file for a service pack).

An example:

   msiexec.exe /i \share_path\DefenseSolutions\MOLE\setup.exe /qn ADDLOCAL=ALL

In Windows, you can enter the command into the Run dialog box (Start > Run) or at the command prompt (Start > Programs > Accessories > Command Prompt).

For installation information and system requirements specific to developing with Defense Solutions, see chapter 6 of this guide, Developing with Defense Solutions.

Next steps

After you install Military Analyst and MOLE, you are ready to perform these next steps:

- In order to have access to all of the Military Analyst and MOLE functionality, your RPF, VPF, DTED, and MOLE data must be in a geodatabase. For information, see Creating geodatabases and importing data in this chapter.

- If you are new to MOLE, step through the MOLE tutorial in chapter 5 of this guide.

- If you intend to program with the Military Analyst or MOLE APIs, use chapter 6 of this guide to help jump start your development work.
Starting and setting up Military Analyst

Enabling the extension

Military Analyst functionality will not be available if the extension is not activated. You must enable the Military Analyst extension in ArcCatalog, ArcMap, and ArcGlobe.

1. Open ArcMap (Start > All Programs > ArcGIS > ArcMap).

ArcMap opens.

2. If the ArcMap dialog box displays, in the Start using ArcMap with area, click A new empty map, then click OK. Otherwise, skip to step 3.

3. From the ArcMap main menu, click Tools > Extensions.

4. On the Extensions dialog box, check the Military Analyst check box.

5. Click Close on the Extensions dialog box.

6. Repeat the above steps, but for ArcCatalog and ArcGlobe instead of ArcMap.

The Military Analyst extension is activated. You are now ready to add layers and start using Military Analyst in ArcGIS Desktop. You may have to first add the Military Analyst toolbar to ArcMap and ArcGlobe; otherwise, skip to Now add layers.

Adding the Military Analyst toolbar to ArcMap and ArcGlobe

1. From the ArcMap main menu, click View > Toolbars > Military Analyst.

The Military Analyst toolbar appears and will appear every time you start ArcMap.

2. Repeat step 1 but in ArcGlobe instead of ArcMap. Make sure you’ve installed and enabled the 3D Analyst extension.

Some of the toolbar buttons will be inactive until you add a Military Analyst layer. The following toolbar images show all buttons active.

You are now ready to add Military Analyst layers to ArcMap or ArcGlobe.
Now add layers

Now you are ready to add Military Analyst layers to ArcMap or ArcGlobe using the Add Military Analyst Layer button. This button opens a dialog box that filters the available catalogs in a database based on catalog type, so if you do not see the catalogs you want, make sure that the Show of type drop-down menu is showing the type you want.

A Military Analyst layer is one that contains required fields and resides in a Military Analyst catalog. Catalogs reside inside a geodatabase.

If you are a new user, you probably have to create one or more Military Analyst catalogs and load data into it. For more information, see Creating geodatabases and importing/loading data later in this chapter.

Starting and setting up MOLE

Starting MOLE in ArcMap and ArcGlobe

To start MOLE in ArcMap or ArcGlobe, you must add the MOLE toolbar. You can add it the same way you add the Military Analyst toolbar (see previous procedure), or, you can use the procedure below.

1. Open ArcMap (Start > All Programs > ArcGIS > ArcMap).
2. If the ArcMap dialog box displays, in the Start using ArcMap with area, click A new empty map, then click OK. Otherwise, skip to step 3.

   ArcMap opens with a new empty map, as shown in the following image.
3. Right-click any ArcMap toolbar, such as the Standard toolbar, then click Military Overlay Editor.
The MOLE toolbar displays. Some buttons will be inactive until you add a MOLE layer or open a map with MOLE layers.

4. Repeat this procedure, but in ArcGlobe instead of ArcMap. Make sure you have enabled the 3D Analyst extension. To enable an extension, from the ArcMap main menu, click Tools > Extensions.

The MOLE toolbar for ArcGlobe appears. Some of its buttons will be inactive until you add a MOLE layer.

You are ready to add MOLE layers to ArcMap and ArcGlobe.
Now add layers

Now you’re ready to add MOLE layers to ArcMap or ArcGlobe using the Add MOLE Data button. A MOLE layer is one that contains a 15-character field and, depending on other MOLE functionality you want to use, meets additional requirements. For details, see Minimum data requirements for MOLE in ArcGIS Desktop Help. For information on creating or importing MOLE data, see Creating geodatabases and importing/loading data later in this chapter.

Starting MOLE for use with ArcGIS Server

If you want to serve MOLE maps using ArcGIS Server, you must have ArcGIS Server 9.3 or higher installed on a server and MOLE must be installed on the server. The MOLE API is not a part of the application development frameworks (ADFs) provided with ArcGIS Server (MOLE does not provide server-side components that are optimized for use with ArcGIS Server), but you can create maps (.mxd and .3dd files) with MOLE symbology and serve them using ArcGIS Server.

Starting MOLE for use with ArcSDE

You can create MOLE ArcSDE feature classes directly in ArcCatalog, or you can import existing MOLE shapefiles and geodatabase feature classes or feature datasets containing MOLE feature classes into an enterprise geodatabase. The steps that you follow to create new MOLE feature classes in an enterprise geodatabase and to view and edit MOLE ArcSDE layers in ArcMap are the same as those for personal geodatabases. For more information, in the ArcGIS Desktop Help table of contents, navigate to Extensions > Military Overlay Editor > The MOLE geodatabase schema > Creating MOLE data in ArcCatalog, then page down to Creating a file geodatabase or personal geodatabase.

When you are working with MOLE layers in an enterprise geodatabase, you must connect to the database before you can create new layers or view and edit existing layers. MOLE layers must also be registered as versioned with the enterprise geodatabase before they can be edited.

Displaying MOLE data in ArcGlobe is similar to displaying it in ArcMap except that you’re working in a 3D environment.

MOLE in ArcGlobe gives you many options for displaying graphics in 3D. If you’ve worked with ArcGlobe before, you are probably already familiar with the options, except possibly for billboarding.

When you work with MOLE in ArcGlobe, it is helpful to keep in mind:

- Force elements are always associated with point features, and tactical graphics are associated with point, line, or polygon features.
- You can apply z-values to the graphics associated with MOLE point, line, and polygon features. You can apply z-values to force elements and tactical graphics.
- You perform extrusions on graphics associated with MOLE line and polygon features when you make them 3D; you billboard MOLE point features to make them 3D. You can extrude line and polygon tactical graphics, and you can billboard force elements and point tactical graphics.
- You can apply the draping display type to any MOLE graphic.
- Extruding, billboarding, and draping affect the graphic associated with the feature. The feature remains at its original x, y, z location in its original form (point, line, or polygon) unless you change it.
When you set up MOLE, you do such tasks as:

- **Set preferences.** Instructions follow.
- **Update your MOLE data.** If you used previous versions of MOLE, consider updating to the latest MOLE schema to ensure you can use all available MOLE functionality at this release. Instructions follow.
- **If you have data in a non-MOLE feature class or shapefile,** you can run an Add MOLE Fields geoprocessing tool on it to ensure the feature class contains all MOLE fields; then you can map your fields to MOLE fields as needed for your data. Instructions follow.
- **If you have spreadsheet data or tabbed/CSV data** (non-feature-class data or non-shapefile data), you can import that data into ArcGIS to create a feature class, then run the Add MOLE Fields tool on it. For instructions on importing non-feature-class data for use with MOLE, see *Import existing data for use with MOLE* in ArcGIS Desktop Help.
- **Create new MOLE data**

### Set preferences

There are several preferences, or defaults, you can set with MOLE. For example, you can:

- **Choose a default military specification** to have MOLE automatically mark unmarked layers it encounters for the first time instead of prompting you each time. The mark tells MOLE which military symbology specification it should use to display the layer’s graphics in the map display.
- **Specify the default Symbol ID code used for new MOLE graphics.** This procedure is especially helpful if you have many symbols in the same layer that have similar 15-character Symbol ID codes.
- **Specify the way MOLE graphics appear when selected.** For a layer, you can change the color of the outline MOLE uses to highlight selected MOLE graphics. You can also further customize how selected graphics will appear for a layer.

For instructions on setting these preferences, see the setting preferences section of *Installation and setup* in ArcGIS Desktop Help.

If you are upgrading MOLE or your MOLE data from a pre-9.2 version of MOLE, you may have to update your MOLE data to the current MOLE schema (which is the same for MOLE 9.2, MOLE 9.3, MOLE 9.3.1, MOLE 9.3.1 SP1, and MOLE 10).

For information on what makes data “MOLE data,” see *Minimum data requirements for MOLE* in ArcGIS Desktop Help.

You must update your MOLE data in any of the following circumstances:

- If you want to use pre-MOLE 9.0 data in MOLE 9.0 or greater.
- If you want to use the fields introduced at MOLE 9.1, Speed and Direction. These fields were added primarily to allow for easier use of wind barbs (meteorological graphics for wind) on MOLE maps. Wind barbs are point tactical graphics.
- If you want to use the new, easier way to turn on and off direction of movement indicators. The new way is to use the field, DirectVis, added to the schema and the MOLE Symbol Editor at 9.2. Enter 0 for off and 1 for on. The default is off. (Note that entering -999 in the Direction field still turns it off as it did in pre-9.2
versions of MOLE, so even if you have 1 in the DirectVis field, if you have -999 in the Direction field, the direction of movement indicator won’t display.)

Schema changes

Schema changes are documented in the release notes of each release. A list of the most significant schema changes since MOLE 2.0 follows.

- At MOLE 10, 9.3.1 SP1, 9.3.1, 9.3 SP1, and 9.3, there were no changes to the schema.
- At MOLE 9.2, the DirectVis field was added to provide an easier way to turn on and off a MOLE graphic’s direction of movement indicator in the map display.
- At MOLE 9.1, two fields, Speed and Direction, were added to point tactical graphics to allow for easier use of wind barbs (meteorological graphics for wind) on MOLE maps.
- At MOLE 9.0, three feature class types were deprecated and their data brought into two other feature class types. The Boundaries, TacticalBio, and TacticalNuclear feature classes were deprecated. In 9.0 and higher, the Boundaries feature class type is handled by the line tactical graphic feature class type, and the TacticalBio and TacticalNuclear feature class types are handled by the point tactical graphic feature class type. For descriptions of MOLE 10 feature class types and a table showing which military symbols are in which MOLE feature class type, see Determining MOLE feature class type for new graphics in ArcGIS Desktop Help.

For detailed field descriptions of the MOLE schema fields for this release, see Attribute data field descriptions in ArcGIS Desktop Help.

Updating pre-9.0 MOLE databases

If you want to use pre-9.0 MOLE data in MOLE 9.3 or greater, you must use the Update pre-9.0 MOLE Database command as described in the following procedure.

1. Install MOLE 9.3 or greater.
2. Open ArcMap.
3. On the MOLE toolbar, click MOLE > Update pre-9.0 MOLE Database.
4. In the Update Older MOLE Database dialog box, navigate to the pre-9.0 MOLE database you want to update. You can select more than one geodatabase (workspace) at a time if the geodatabases are in the same directory.
5. In the list area, highlight the name of the geodatabase(s) you want to update, then click Update.

MOLE examines the feature classes and datasets in the selected database(s) and validates each feature class’s extension class ID. If the class extension is missing or incorrect, MOLE clears the class extension information. When MOLE is finished updating the pre-9.0 database to a MOLE 9.0 database, it displays a message box confirming that the update is complete. It saves the database to the same directory as the original database.

Note: MOLE 2.0 permitted the creation of three feature classes in an 8.x geodatabase that contained class extensions incompatible with MOLE 9.0 and greater. These feature classes are Boundaries, TacticalBio, and TacticalNuclear. Now that you have updated the database, the Boundaries feature class type will
be handled by the line tactical graphic feature class type, and the TacticalBio and TacticalNuclear feature class types will be handled by the point tactical graphic feature class type.

If you want the updated database to contain all of the fields added to the MOLE schema since 9.0, continue to the next step. Adding all fields in the current MOLE schema is not required, but it ensures that you have access to all MOLE functionality. Aside from the Symbol_ID field, no field is required to be populated; you can populate the fields at a later date.

6. Open ArcToolbox and open the Add MOLE Fields Single geoprocessing tool. For more information, see chapter 4, *Quick reference*.

The Add MOLE Fields Single window appears.

7. Use this geoprocessing tool on each feature class in the database you just updated in step 5:

A. In the Input data element area, click the Browse button and navigate to a feature class in the database you updated in step 5.

B. Click the MOLE Output Type drop-down menu and select the type of feature class you navigated to in the previous step. For more information on determining the appropriate input or output type, see *Determining MOLE feature class type for new graphics* in ArcGIS Desktop Help.

C. Click the Military Standard drop-down menu and select the military symbology specification you want to mark this feature class as.

D. In the Output data element area, click the Browse button and navigate to the geodatabase in which you want to store the new feature class.

E. Click OK.

The feature classes you used the tool on now contain all MOLE 9.3.1 fields (or 9.3.1 SP1 fields).

F. Repeat step 7 for as many feature classes as you want to add MOLE fields to.
Installing and Getting Started with Defense Solutions

For more information:

• For detailed tool descriptions and tips for using MOLE geoprocessing tools, see the context-sensitive help panel that comes with the tools by clicking Show Help from within each tool.

• For an overview of MOLE geoprocessing tools and links to general information on using geoprocessing tools, see chapter 4, *Quick reference*.

**Methods for updating existing MOLE data to the current MOLE schema**

If you have MOLE 9.0 or 9.1 data, you can use one of several methods to update your data to the MOLE 10 schema.

Updating to the current schema technically means adding all MOLE fields that have been added to the schema since you last updated your version of MOLE. However, you do not have to add all of the MOLE fields that are new to your data in order to use some of the new fields. You have the option of adding all of the MOLE fields available by performing a full update or adding only the fields you want that are new to your data by performing a partial update.

In either case, it is important to keep in mind that if you already have fields in your data that are storing the same information MOLE fields will store for you, you can map your existing fields to MOLE fields even if they do not have the field names MOLE expects. The only requirements for this mapping are:

• That your fields be the same data type as the MOLE fields
  and
• That their number of characters fall within the MOLE’s default character limits (unless you change the character limit to accommodate your number of characters).

For example, you may have a field that sets the display (on or off) for direction of movement indicators using the same values MOLE does for on and off (1 and 0, respectively). But perhaps your field is named DirIndicator instead of DirectVis. In this case, you would not have to add the DirectVis field to your data, but instead just map your DirIndicator field to MOLE’s DirectVis field. On the other hand, no harm is done if you perform a full update, which will add MOLE’s DirectVis field, then do the field name mapping later. For more information, see *To map your field names to MOLE field names* in ArcGIS Desktop Help.

The following procedures describe how to perform a full update and a partial update.

A third option is to import your data into empty MOLE feature classes that are based on the MOLE 10 schema. Several import options are available to you; for more information, see *Importing existing data for use with MOLE* topic in ArcGIS Desktop Help.

Before you update any data, it is also important to weigh the update task against starting from scratch with a brand new geodatabase. It may be easier to create a new MOLE geodatabase and then populate it from scratch or import your existing data into it.

**To perform a full update**

To be able to use all available MOLE functionality within a geodatabase, the geodatabase should have at least four MOLE layers so that the geodatabase can contain each of the four MOLE feature class types (to cover all the categories of symbols defined in the military symbology specifications):...
• Force element feature class—This feature class stores ArcGIS point features. It stores force unit, equipment, installation, SIGINT, and MOOTW symbols.

• Point tactical graphic feature class—This feature class stores ArcGIS point features. It stores symbols such as combat services support, general maneuver, and METOC symbols.

• Line tactical graphic feature class—This feature class stores ArcGIS line features. It stores symbols such as combat services support, advance arrows, bearing lines, and METOC symbols.

• Area tactical graphic feature class—This feature class stores ArcGIS area features. It stores symbols such as combat services support and mobility-survivability symbols.

However, your geodatabase may not contain all four types because you may not need all four. The following procedure steps you through adding fields to one feature class. The procedure is the same for each feature class type; perform it on as many feature classes as needed. For more information on determining which MOLE feature class type your data warrants, see Determining MOLE feature class type for new graphics in ArcGIS Desktop Help.

If you don’t have each type represented in your database but want to, you can add the ones you don’t have by creating MOLE feature classes in ArcCatalog. For details, see Creating MOLE data in ArcCatalog in ArcGIS Desktop Help.

1. Open ArcToolbox and open the Add MOLE Fields Single geoprocessing tool. For information on opening this tool, see Getting started geoprocessing with Defense Solutions in chapter 4 of this guide.

The Add MOLE Fields Single window appears.

You must use this window (geoprocessing tool) on each feature class you want to perform a full update on.

2. In the Add MOLE Fields Single window:

   A. In the Input data element area, click the Browse button and navigate to the MOLE feature class you want to perform a full update on. You can also select a non-MOLE feature class—a simple ArcGIS feature class (point, line, or area)—in this step if you want to convert it to a MOLE feature class.
B. Click the MOLE Output Type drop-down menu and select the type of feature class you navigated to in the previous step.

C. Click the Military Standard drop-down menu and select the military specification you want to mark this feature class as.

D. In the Output data element area, click the Browse button and navigate to the geodatabase you want to store the new feature class in.

E. Click OK.

The feature classes you used the tool on now contain all MOLE 10 fields.

F. Repeat step 2 for as many feature classes as you want to add MOLE fields to.

Now you are ready to use MOLE user interface commands on the data.

If some of the fields in your input feature class already contained MOLE data but had field names other than those MOLE expects, see To map your field names to MOLE field names in ArcGIS Desktop Help.

To perform a partial update

You can add only the fields you want to your existing data. For example, you may be upgrading a MOLE 9.0 dataset and want to use the new DirectVis field but not want to use the new wind barb fields, Speed and Direction.

MOLE fields are added the same way you add any attribute fields to an ArcGIS dataset. Although there are several ways to add fields, the following procedure steps you through a method of adding fields from within ArcMap.

1. In ArcMap, add the MOLE feature class you want to perform a partial update on. Use the Add MOLE Data button on the MOLE toolbar to add the feature class.

   Tip:
   
   • If you are adding the new DirectVis field, the type of MOLE feature class you opened should be force element or point tactical graphic.
   • If you are adding the Speed and Direction fields that were added to the MOLE schema at 9.1, the type of feature class you opened should be point tactical graphic.

   Note that to make data MOLE data and to be able to add it with the Add MOLE Data toolbar button, it must contain a 15-character attribute field named Symbol_ID. The field must be a data type of text, character, or string. Adding data with this button allows it to be symbolized according to the military specification you choose/have chosen for it.

2. In the ArcMap table of contents, right-click the feature layer portion of the MOLE group layer.

3. Click Open Attribute Table.

4. In the Attributes window, click the Options button.

5. On the menu that appears, click Add Field.

6. On the Add Field dialog box:

   • In the Name text box, type the MOLE required name for the first MOLE field you want to add.
Installation and setup

Creating MOLE data

- Click the Type drop-down menu and select the data type for the field. If the type is Text, type the default character limit for the field in the value text box for the Length property.

For a list of MOLE required names, data types, and default character limits (lengths), see Attribute data field descriptions in ArcGIS Desktop Help.

For example:

- If you were adding the DirectVis field, you’d give it a Name of “DirectVis” and a Type of Short Integer.
- If you were adding the Direction field, you’d give it a Name of “Direction” and a Type of Double.
- If you were adding the Speed field, you would give it a Name of “Speed”, a Type of Text and a Length of 10.

When you create MOLE data, you create data in a native ArcGIS format that also adheres to specific requirements tied to military specifications.

To create MOLE data, you typically use one or more of the following methods:

1. **Create MOLE data from within ArcMap.** This includes drawing/adding MOLE graphics to a map in ArcMap.

2. **Create MOLE data using ArcCatalog** to create one or more empty MOLE geodatabases, MOLE feature classes, MOLE feature datasets, or MOLE shapefiles, then populate them in one of the many ways you can populate any ArcGIS tables, including drawing MOLE graphics in ArcMap. For more information on creating MOLE data this way, see Creating MOLE data in ArcCatalog in ArcGIS Desktop Help. Exercise 1 in the tutorial (chapter 5 of this guide) steps you through creating the main types of MOLE data.

3. **Add MOLE fields to your existing data by** using one or more of the following three methods:
   - By using one of the Add MOLE Fields geoprocessing tools in ArcToolbox
   - By using the attribute table in ArcMap.
   - By using the table view in the ArcCatalog Preview pane.

4. **Map applicable fields in your existing data to** MOLE fields using the Layer Properties dialog box in ArcMap.

5. **Import text, spreadsheet, or CSV data** into ArcMap, save it as a feature class, then add MOLE fields to it or map your fields to the field names MOLE expects.

6. **Use a combination of the above three methods (numbers 3, 4, and 5) as required by your existing data.**

For details on each of the above methods, see Creating MOLE data in ArcGIS Desktop Help.

**Geodatabase versus shapefile**

It is recommended that you use or create a MOLE geodatabase (single-user or multiuser) to store your MOLE data rather than shapefiles.

Storing MOLE data in a geodatabase lets you use all of the functionality and benefits offered by the ArcGIS geodatabase data model:
• More modeling, analysis, and cartographic functionality is available for geodatabases than for shapefiles, such as geometric networks, topology, cartographic representations, dimensions, and raster data management.

• Geodatabases have data integrity features built in, such as domains, subtypes, and relationship classes.

Creating MOLE data with an ArcView license

If you are working with an ArcView license, you will not be able to create a MOLE feature class using the New Feature Class wizard in ArcCatalog. This is because MOLE feature classes are custom ArcGIS objects, and the ArcView level of licensing prohibits the creation of custom ArcGIS objects (or custom object feature classes).

However, you can get the same result by using ArcView to create a standard ArcGIS point, line, or area feature class, then using the Add MOLE Fields Single geoprocessing tool on it.

You can copy and paste existing MOLE feature classes into a geodatabase you’ve created. You can rename the feature classes within it and remove feature classes from it. You can also copy the feature classes in it to other databases and data repositories.

Creating geodatabases or importing/loading data

In order to have access to all of the Military Analyst and MOLE functionality, your RPF, VPF, DTED, and MOLE data must be in a geodatabase.

For Military Analyst, this means:

• Your data should reside in Military Analyst catalogs, which reside in ArcGIS geodatabases. If you are a new user, you will likely need to create Military Analyst catalogs for your data, then load your data into them. Creation and data loading of Military Analyst RPF, DTED, and VPF catalogs take place in ArcCatalog; Military Analyst data management geoprocessing tools are available to help create and load data. For example, existing Military Analyst RPF, DTED, and VPF catalogs can be loaded by using the Load MA Catalog command in ArcCatalog. (See the ArcGIS Desktop help for step-by-step instructions.)

• A Military Analyst layer is typically one that resides in a Military Analyst catalog.

• Although some Military Analyst tools and commands can be used on non-Military Analyst layers, such as the Coordinate tool, most require that your data be in Military Analyst catalogs in order for you to get the most out of Military Analyst.

• To add a Military Analyst layer to a map in ArcMap or ArcGlobe (and to subsequently use Military Analyst tools and commands on it), you must use the Add Military Analyst layer button on the Military Analyst toolbar.

• Troubleshooting: If the data in a new Military Analyst catalog does not display in ArcMap, check for data location, scale dependency, and layer selection, as follows:
  • (DTED and RPF data) Data location. The path to the data must be correct; that is, the path should not reflect the directory structure on someone else’s machine. To check, in ArcCatalog, select the catalog in the left pane. In the right pane, select the Contents tab. The paths to the files appear beneath FULL_NAME. If the paths are fictitious, create and load a catalog in a location your machine can access.
• (VPF data) Scale dependency. If a grayed-out check mark appears next to a VPF catalog or data layer, the data is not being displayed because of scale. Right-click the catalog or data layer to display Properties and then do the following:
  • At the VPF catalog level, on the VPF Layers tab, in the VPF Layer Display Options area, uncheck Use Scale Dependency.
  • At the data layer level, on the General tab, select Show layer at all scales.

• (VPF data) Layer selection. When you first add a VPF catalog to an ArcMap display, the default is for no data to be displayed. To display data, right-click the catalog and go to Properties. Then, on the VPF Layers tab, in the VPF Feature Selection area, check off the layers and/or features you want to display.

For MOLE, this means:
• Your data must meet some minimum requirements. A MOLE graphics layer (also known as a MOLE layer) is one that meets these requirements. For details, see Minimum data requirements for MOLE in ArcGIS Desktop Help.

• If your data meets those requirements, you can view it in ArcMap and ArcGlobe and you can add all MOLE fields to it in ArcCatalog. Once you’ve added all MOLE fields to it, you can take advantage of all of MOLE’s functionality. You may have to first map your existing fields to field names MOLE expects. For more information, see To map your field names to MOLE field names in ArcGIS Desktop Help.

• There are several ways you can populate MOLE feature classes (feature classes reside in geodatabases) with existing data or data you create from scratch. For more information, see Creating MOLE data in ArcGIS Desktop Help.

• An important thing to keep in mind when working with MOLE data is that it is based off ArcGIS feature class types of point, line, and polygon, but that MOLE feature classes are custom and are named a bit differently. So, for example, when you create a MOLE feature class, you must look for a name such as “MOLE force element” (instead of the regular ArcGIS point feature class) in the feature class list in ArcCatalog’s New Feature Class wizard. For more information, see The MOLE group layer and layer properties dialog boxes in chapter 4 of this guide.

• To get the most out of MOLE, use MOLE tools and commands on the MOLE layer. Add the MOLE layer using the Add MOLE Data button instead of the ArcGIS Add Data button.
Quick reference

In This Chapter

- Getting started geoprocessing with Defense Solutions
- Military Analyst quick reference
- MOLE quick reference

This chapter provides brief descriptions of the main user interface items in the Military Analyst and MOLE applications.
Getting started geoprocessing with Defense Solutions

Almost all uses of GIS involve the repetition of work, and this creates the need for methods to automate, document, and share multiple-step procedures. Geoprocessing supports the automation of workflows by providing a rich set of tools and a mechanism to combine a series of tools in a sequence of operations using models and scripts.

A model lets you perform a workflow, modify it, document it, and repeat it over and over again with a single click. That is, it lets you store ordered steps and properties associated with them, such as assumptions, tools, datasets, and parameter values.

Common geoprocessing operations (also known as model building) are geographic feature overlay, feature selection and analysis, topology processing, raster processing, and data conversion. An example of a geoprocessing sequence is: clip the dataset, select a part of the dataset, then intersect two datasets.

ArcGIS uses a toolbox hierarchy concept to organize its geoprocessing tools. The tools, toolsets, and toolboxes are stored inside the ArcToolbox software application.

Like most ArcGIS extensions, Military Analyst and MOLE each has a toolbox in ArcToolbox. Each toolbox is a standalone toolbox located at the highest level within the ArcToolbox structure.

Like most ArcGIS toolboxes, it contains one or more toolsets that form a category of tools. The Military Analyst toolbox contains several toolsets. The MOLE toolbox contains one toolset, Utilities. These toolsets and tools are described in detail later in this section.

You can access the MOLE tools from ArcCatalog or any application that supports ArcToolbox, such as ArcMap. Depending on your operating system and settings, you may have to add the Military Analyst and/or MOLE toolbox to make it available in ArcToolbox.

1. If you haven’t already, install Military Analyst and/or MOLE.
2. If you want to add the Military Analyst toolbar, make sure you’ve enabled the extension (in ArcMap, click Tools > Extensions, then check the Military Analyst checkbox).
3. Open ArcToolbox. For example, open ArcCatalog (Start > Programs > ArcGIS > ArcCatalog), then click Window > ArcToolbox.
4. In the ArcToolbox Favorites tab (tabs are on the bottom), right-click ArcToolbox.
5. Click Add Toolbox.

Adding Defense Solutions toolboxes

7. Click to select the toolbox you want to add. You can add both Defense Solutions toolboxes at once by clicking Military Analyst and Military Overlay Editor (MOLE) Tools.

8. Click Open.

The toolbox(es) you selected is added to ArcToolbox. The toolbox’s toolset(s) and tools are also added. The following image shows the ArcToolbox Favorites tab after the MOLE toolbox was added.

To use a geoprocessing tool, double-click it to open its window. The illustration below shows the Add MOLE Fields Single tool’s window.

For information on using a tool, click Show Help in the tool.

For additional ways to access geoprocessing help, see the documentation section in chapter 1, About Defense Solutions and this guide.
Installing and Getting Started with Defense Solutions

**Analysis toolset**

The Analysis toolset consists of:

- A Link Tools toolset
- A Terrain Analysis toolset

**Link toolset**

- Create Links—Creates a line feature class that links points in a feature class based on from- and to-attributes in a separate table.
- Find Shortest Path & Critical Links—Computes the shortest path and any critical links between selected points. A critical link is a link that can be completely isolated from the network by being severed at one endpoint.
- Recalculate Links—Updates the geometry of a line feature class from its topological attributes and a point feature class. This tool is intended to run on a feature class that was produced by the Create Links tool. Run this tool when the point locations have changed since you generated links from them.

**Terrain Analysis toolset**

- Highest/Lowest Point by Extent—Finds the highest or lowest points for a surface within a defined extent.
- Hillshade—Creates a shaded-relief raster of the input surface based on a light source.
- Linear Line of Sight—Determines the visibility, based on the elevation, of all the points in a straight line on a surface between a specified observer and target points and generates a line shapefile to display this information.
- Linear Line of Sight From Features—Builds a 3D polyline of visible and invisible paths between the observer points and target points as well as a point feature class of obstructions.
- Path Slope—Finds the slope of the segments of an input polyline path that exists over a surface.
- Radial Line of Sight—Determines what region of a surface may be seen from input observers.
- Z-Factor Tool—For geographic datasets, this tool determines the z-factor for scaling z-units into xy-units. The z-factor is based on the middle latitude of the dataset.

**Data Management toolset**

In order to have access to all of the Military Analyst functionality, your RPF, VPF, and DTED data must be in a geodatabase. The Data Management tools allow you to create catalogs (catalogs are inside geodatabases) and load your data into catalogs.

The Create DTED Catalog, Create RPF Catalog, and Create VPF Catalog scripts allow you to create each type of Military Analyst catalog.

The Extract RPF Catalog Items tool lets you extract RPF tiles from a Military Analyst catalog by specifying corner coordinates and other options.
The Load MA Catalog tool allows you to load data into an already-existing Military Analyst catalog.

**Geometry toolset**

The Geometry Import set of tools consists of the Table To Ellipse, Table To Geodesy Line, Table To Line, Table to Point, Table To Polygon, and Table To Polyline tools. These tools convert tables, text and DBF files, and spreadsheets into each respective geometry type in ArcMap, ArcCatalog, or ArcGlobe. Data with the required fields can be easily converted.

**Samples toolset**

This toolset provides sample scripts for creating and loading DTED catalogs, RPF catalogs, and VPF catalogs. It also provides a script for loading non-RPF data, which allows you to combine RPF and non-RPF raster datasets into a Military Analyst RPF catalog.

**Utilities toolset**

Contains tools for converting OILSTOCK overlay files to shapefiles, and converting other data types:

- **Add Observer Fields**—A script that adds observer fields to an input feature class.
- **Convert Coordinates in File**—A tool that converts coordinates in a point feature class or a table to and from the following: point features, decimal degrees (DD), degrees-minutes-seconds (DMS), Universal Transverse Mercator (UTM), Military Grid Reference System (MGRS), and United States National Grid (USNG) fields.
- **Create Observers From Table**—A script that creates a set of observer points from an input table. Each row in the table becomes a separate observer point.
- **Create Single Observer**—A script that creates a single observer point in a new feature class.
- **Import OILSTOCK Overlay**—A tool that converts OILSTOCK Overlay files to shapefiles. It supports the conversion of OILSTOCK Overlay files containing map coordinates and their symbology to shapefiles and an associated layer file. All basic geometries are converted to their own shapefiles.

**The Add MOLE Fields tool**

If you have the ArcEditor or ArcInfo license level, this tool allows you to add MOLE fields to multiple non-MOLE feature classes or shapefiles at one time and output them as a set of MOLE shapefiles. The feature classes and/or shapefiles you select as input can be point, line, or area. They will become the same type of output, either all force element shapefiles or all tactical graphic shapefiles. You cannot specify a name for the output shapefile or shapefiles; you must use the name MOLE assigns.

**The Add MOLE Fields Single tool**

This tool, introduced after the Add MOLE Fields tool, allows you to add MOLE fields to one non-MOLE feature class or shapefile and output it to one MOLE feature class or MOLE shapefile. The feature class or shapefile you select as input can be point, line, or area. You must have the ArcEditor or ArcInfo level of licensing to output to shapefile.
The Convert Military Standard tool

This tool allows you to convert a MOLE feature class or MOLE shapefile to a different military symbology standard. The output can be a feature class or shapefile.
Military Analyst quick reference

Toolbar in ArcMap

 Toolbar in ArcGlobe
The Military Analyst Options dialog box contains options not found on an individual tool’s dialog box and applies globally to all applicable tools. The Options dialog box contains settings for units, output workspace, wireframe, uniform rendering, terrain analysis, symbology, and coordinates.
Creating and loading Military Analyst catalogs

In order to have access to all of the Military Analyst functionality, your RPF, VPF, and DTED data must be in a geodatabase. For details, see Creating geodatabases and importing data in chapter 3 of this guide.

Data management

Military Analyst makes it easy to manage the display and storage of RPF, DTED, and VPF data using catalogs. Creation and data loading of Military Analyst RPF, DTED, and VPF catalogs take place in ArcCatalog. Military Analyst catalogs provide the ability to load multiple datasets from multiple subfolders in a single process known as recursive data loading, which minimizes the amount of effort required to populate the catalogs with data. The catalogs also allow you to manage how the data is displayed in ArcMap; this is controlled from the catalog’s Layer Properties dialog box. A key component of each type of catalog is the wireframe, a color-coded footprint showing the geographic extent of the data contained by the catalogs.

RPF and DTED catalogs are customized geodatabase raster catalog objects that can be created in a personal geodatabase (PGDB) or an enterprise geodatabase). As such, they have all the functionality of GDB raster catalogs, along with the additional display behavior and recursive data-loading capabilities provided by Military Analyst. See ‘Building a Geodatabase’ in the ArcGIS Desktop Help for more information on raster catalogs. If the catalog is created in a PGDB, the RPF frame files or DTED cells are referenced from their location on disk (unmanaged). If the catalog is created in an SDE GDB, the RPF frame files or DTED cells in the catalog are actually converted to SDE raster datasets and are stored in the underlying relational database management system (RDBMS—managed).

VPF catalogs are custom geodatabase feature classes that reference VPF feature classes on disk. They expand upon the ArcGIS native VPF reading capability by allowing you to select and display as many feature classes as desired from multiple VPF databases and products, rather than having to open one feature class at a time.

VPF feature classes are listed on the Layer Properties dialog box with clear and unambiguous names, making it easy for you to select the feature classes that you want to display.

VPF data can be displayed using the default renderer or the GeoSym renderer. The GeoSym renderer allows you to display GeoSym symbology.

The Coordinate tool’s primary interface, the Coordinate Tool dialog box, is a docking window. This allows you to dock the window in ArcMap so it will remain open and active even while you are using another tool. In this way, you can have MGRS coordinates displaying constantly as you move the mouse pointer around the data frame. You can convert coordinates by typing them into the text boxes on the Coordinate Tool dialog box in any of the supported coordinate systems, then specifying a datum. More than 200 different datums are supported. You can also find and convert the coordinates for a specific point by clicking the desired location in a georeferenced raster or vector file with the Coordinate Tool dialog box open. In addition, the Coordinate tool allows you to find the location of a point with known coordinates. For more information, see An overview of the Coordinate tool in ArcGIS Desktop Help.
Terrain analysis tools

The Terrain Analysis tools in Military Analyst are surface analysis operations commonly performed by the defense and intelligence user. In Military Analyst, all the terrain analysis functions can be performed using Military Analyst DTED catalogs as the input surface, which allows cross-tile surface analysis of DTED data.

Layer list control

The Layer list control on the Military Analyst toolbar lists all available raster and surface layers in the table of contents (TOC) of the active ArcMap data frame, including Military Analyst RPF and DTED catalogs. The layer that is currently selected will be the input surface layer for the highest/lowest point, hillshade, and extract tools.

Mosaic command

The Mosaic command can be used to merge and match the boundaries of the constituent raster datasets from Military Analyst RPF and DTED catalogs into single, file-based or SDE raster datasets. The output formats include SDE, personal geodatabase raster, GRID, IMG, and TIFF. The tool is flexible enough to allow you to mosaic a selection of adjacent rasters, all the members of the catalog at once, or rasters in the visible extent of the data frame.

Extract tool

The Extract tool is another mosaicking function of Military Analyst that performs a task similar to the Mosaic command. However, this tool allows you to specify a region by graphic input. The raster data displayed with the catalog in that area can be clipped and mosaicked into a file-based or SDE raster. The Extract tool uses the layer selected in the Layer list control as the input layer.

The Mosaic command and Extract tool only function with Military Analyst RPF and DTED catalogs.

Radial Line of Sight

The RLOS function is an implementation of the Spatial Analyst viewshed function. It calculates a viewshed, an analysis of the visibility of target pixels surrounding an observer point based on their elevation. It allows the interactive creation of observers using the Coordinate tool and the use of DTED catalogs or any ArcGIS software-supported raster surface dataset for performing this analysis.

Linear Line of Sight

The LLOS function requires the input of two points, an observer and a target, as well as their heights above the surface. Military Analyst uses these inputs to calculate what areas of the surface can be seen from the start point along a line extending to the target. The function also allows you to quickly determine if the target is visible to the observer. A color-coded polyline and profile graph are the results of this analysis. The LLOS function uses DTED catalogs or any ArcGIS software-supported raster surface dataset for the input surface.

Hillshade command and tool

The Hillshade function creates a qualitative shading of a surface’s topography based on a hypothetical light source. Creating a hillshade for surface data adds a degree of
realism to the experience of viewing the data. It can give the surface an interpretive 3D look during display in ArcMap. Military Analyst provides two methods for generating hillshades. The Hillshade command operates on either raster surface datasets or DTED catalogs.

The Hillshade tool, on the other hand, only operates on DTED catalogs. This tool allows you to specify an area of interest by drawing a bounding rectangle in the data frame, then generates a hillshade for it. This tool is best used for smaller areas of interest.

### Highest/Lowest Point tools

The Highest and Lowest Point tools function the same way. Both operate on the surface dataset or DTED catalog currently selected in the Layer list control. The tools analyze the pixels to determine which ones have the highest or lowest value within the box, create a point shapefile, and place a point feature at the location of the highest or lowest point. The elevation of the point is listed with the shapefile in the TOC.

The Geodesy tools provide the capability to calculate and display linear distances and projected ellipses that are spatially accurate and geodetically correct in any projection and any part of the world. Projections inherently contain distortion; geodesy lines and ellipses account for this distortion.

### Geodesy Graphic tool

The Geodesy Graphic tool is a quick and easy way to visualize geodesic, great circle, and rhumb lines in ArcMap. The parameters for the lines, including line type, distance units, and azimuth units, are defined on the Military Analyst Options dialog box.

### Geodesy Calculator

The Geodesy Calculator offers flexibility when calculating geodesy distances, with options to display and label output geodesic, great circle, and rhumb lines. All the parameters for the calculations, including line type, distance units, and azimuth units, are defined on the Geodesy Calculator dialog box. Input coordinates are interactively specified using the Coordinate tool.

### Range Rings tool

The Range Rings tool allows you to quickly visually determine information important for mission planning, such as weapon and aircraft ranges. The output of the Range Rings tool is spatially correct and accurate in any projection. Input center point coordinates are interactively specified using the Coordinate tool.
Conversion tools

The Conversion tools’ group of functionality consists of the Convert Coordinates in File batch coordinate conversion command and the Convert VPF Features function.

Convert Coordinates

The Convert Coordinates function allows you to convert all the coordinates in a file, whether contained in a field within a table or the geometry of a feature class. The command supports the same coordinate formats as the Coordinate tool: decimal degrees, DMS, UTM, and MGRS.

Convert VPF Features

The Convert VPF Features function allows you to convert VPF data from a VPF catalog to shapefiles, personal geodatabase feature classes, or SDE feature classes. You can convert all the features within selected VPF feature classes or all the VPF features within the visible extent of the ArcMap data frame, or you can select specific features within the VPF feature classes and convert them.

Several key Military Analyst tools have now been integrated into the ArcGlobe structure and are available for use, including the Coordinate tool, visibility analysis with the Threat Dome tool, and automatic generation of fly-through animation.

Fly Through tool

You can use the Fly Through tool to generate animation in ArcGlobe to fly along a designated flight path or to rotate on a designated point. There are four types of data that can be added for a Military Analyst fly-through in ArcGlobe: a polyline or LLOS feature class, an RLOS observer, a new line, or a new observer point.

Threat Dome tool

The Threat Dome tool works the same in ArcGlobe as it does in ArcMap; the only difference is you must add an already-created RLOS observer shapefile to ArcGlobe—it cannot be created there.

You can specify the default output workspace in which the threat dome features generated with the Threat Dome tool are stored by setting this property on the Military Analyst Options dialog box in ArcGlobe.
One of the components of the Military Analyst RPF and DTED catalogs is a wireframe feature layer representing the geographic extents of each of the constituent rasters within the catalog. The wireframe is color coded to differentiate between the various RPF and DTED products contained by the respective catalog; the product represented by each color is explained in the Military Analyst catalog wireframe symbology table.

<table>
<thead>
<tr>
<th>Product</th>
<th>Scale</th>
<th>Color Description</th>
<th>Red</th>
<th>Green</th>
<th>Blue</th>
</tr>
</thead>
<tbody>
<tr>
<td>GNC</td>
<td>1:5,000,000</td>
<td>Mars Red</td>
<td>255</td>
<td>0</td>
<td>0</td>
</tr>
<tr>
<td>JNC</td>
<td>1:2,000,000</td>
<td>Electron Gold</td>
<td>255</td>
<td>170</td>
<td>0</td>
</tr>
<tr>
<td>ONC</td>
<td>1:1,000,000</td>
<td>Solar Yellow</td>
<td>255</td>
<td>255</td>
<td>0</td>
</tr>
<tr>
<td>TPC</td>
<td>1:500,000</td>
<td>Medium Apple</td>
<td>85</td>
<td>255</td>
<td>0</td>
</tr>
<tr>
<td>LFC</td>
<td>1:500,000</td>
<td>Big Sky Blue</td>
<td>0</td>
<td>197</td>
<td>255</td>
</tr>
<tr>
<td>JOG</td>
<td>1:250,000</td>
<td>Cretean Blue</td>
<td>0</td>
<td>112</td>
<td>255</td>
</tr>
<tr>
<td>TFC</td>
<td>1:250,000</td>
<td>Amethyst</td>
<td>197</td>
<td>0</td>
<td>255</td>
</tr>
<tr>
<td>ATC</td>
<td>1:200,000</td>
<td>Olivenite Green</td>
<td>168</td>
<td>168</td>
<td>0</td>
</tr>
<tr>
<td>TLM 100</td>
<td>1:100,000</td>
<td>Tuscan Red</td>
<td>168</td>
<td>0</td>
<td>0</td>
</tr>
<tr>
<td>TLM 50</td>
<td>1:50,000</td>
<td>Malachite Green</td>
<td>0</td>
<td>168</td>
<td>132</td>
</tr>
<tr>
<td>HA</td>
<td>Various</td>
<td>Ultra Blue</td>
<td>0</td>
<td>77</td>
<td>168</td>
</tr>
<tr>
<td>CO</td>
<td>Various</td>
<td>Cattleya Orchid</td>
<td>168</td>
<td>0</td>
<td>132</td>
</tr>
<tr>
<td>OPAREA</td>
<td>Various</td>
<td>Gray 50%</td>
<td>130</td>
<td>130</td>
<td>130</td>
</tr>
<tr>
<td>CG</td>
<td>Various</td>
<td>Fir Green</td>
<td>38</td>
<td>115</td>
<td>0</td>
</tr>
<tr>
<td>Combat Charts</td>
<td>Various</td>
<td>Dark Navy</td>
<td>0</td>
<td>38</td>
<td>115</td>
</tr>
<tr>
<td>Miscellaneous(MM)</td>
<td>Various</td>
<td>Cocoa Brown</td>
<td>137</td>
<td>90</td>
<td>68</td>
</tr>
<tr>
<td>CIB1</td>
<td>1 meter</td>
<td>Light Sienna</td>
<td>205</td>
<td>170</td>
<td>102</td>
</tr>
<tr>
<td>CIB5</td>
<td>5 meter</td>
<td>Medium Olivenite</td>
<td>171</td>
<td>205</td>
<td>102</td>
</tr>
<tr>
<td>CIB10</td>
<td>10 meter</td>
<td>Atlantic Blue</td>
<td>102</td>
<td>153</td>
<td>205</td>
</tr>
<tr>
<td>non-RPF</td>
<td>Various</td>
<td>Gray 70%</td>
<td>78</td>
<td>78</td>
<td>78</td>
</tr>
<tr>
<td>DTED 0</td>
<td>1000 meter</td>
<td>Cantaloupe</td>
<td>255</td>
<td>167</td>
<td>127</td>
</tr>
<tr>
<td>DTED 1</td>
<td>100 meter</td>
<td>Poinsettia Red</td>
<td>230</td>
<td>0</td>
<td>0</td>
</tr>
<tr>
<td>DTED 2</td>
<td>30 meter</td>
<td>Raw Umber</td>
<td>168</td>
<td>112</td>
<td>0</td>
</tr>
<tr>
<td>DTED 3</td>
<td>Unknown</td>
<td>Lime Dust</td>
<td>215</td>
<td>215</td>
<td>158</td>
</tr>
<tr>
<td>DTED 4</td>
<td>Unknown</td>
<td>Macaw Green</td>
<td>152</td>
<td>230</td>
<td>0</td>
</tr>
<tr>
<td>DTED 5</td>
<td>Unknown</td>
<td>Larkspur Blue</td>
<td>68</td>
<td>101</td>
<td>137</td>
</tr>
</tbody>
</table>
MOLE quick reference

**Toolbar in ArcMap**

- **MOLE drop-down menu**
- **MOLE Symbol Editor**
- **Add MOLE Data**
- **Identify Graphics**
- **Select one or more MOLE graphics**
- **Drop-down menu that lets you define the magnitude of the property**
- **Refresh all MOLE graphics in selected layers**
- **Text Height**
- **Stack Height**
- **Leader Distance**
- **Graphic Height**
- **Toggle Stacking**
- **Run this command on your database if it is a pre-9.0 MOLE database. For details, see Updating pre-9.0 MOLE databases in Updating your MOLE data to the current MOLE schema in chapter 3 of this guide.**

**Notes**

Leadering and stacking with the toolbar are ways to group MOLE graphics quickly for map readability.

Graphic Height, Text Height, Leader Distance, and Stack Distance let you define the magnitude of a property (graphic/text size or leader/stack distance) by clicking and dragging a box or a circle in the map display. Graphic Height is also known as Set Size.

**Toolbar in ArcGlobe**

The MOLE toolbar buttons and commands in ArcGlobe are the same as their counterparts in ArcMap, with the exception of the Leader Distance and Stack Distance buttons, which are unavailable in ArcGlobe.
The MOLE Symbol Editor allows you to edit a MOLE graphic and its attributes and preview the changes before you apply them. It also allows you to quickly change one graphic to another graphic using your choice of edit methods:

- Typing in the “plain English” name of the symbol into the Search for text box to search through all MIL-STD-2525B Change 2 and APP-6A graphics.
- Navigating through the Symbol Library (the tree view in the left pane) to select the graphic you want. All MIL-STD-2525B Change 2 and APP-6A graphics are in this symbol library.
- Entering values into the 15 boxes that make up the 15-character Symbol ID code. This is known as manually editing the code. You can also manually edit the Symbol ID code outside of the MOLE Symbol Editor by editing the graphic’s attribute table (the attribute table of the graphic’s layer’s associated feature layer).

**MOLE Symbol Editor areas described**

![Diagram of MOLE Symbol Editor with an armored cavalry unit selected in the Symbol Library pane.](image-url)
MOLE Symbol Editor fields described

Symbol library
Contains all MOLE symbols. With each character you type in this search box, MOLE updates the symbol library tree above it to display all items that match the letters you've typed.

Indicates whether the element is located at its current position or is anticipated to be there in the future.

If you know your Symbol ID code values, you can check this box, then type the values in the boxes to the left.

Applies your changes to the map display. If you click OK, then save your edit session edits, the changes you make are applied (saved) to your source data as well.

The threat of the element. Values include friend, hostile, and neutral.

Values (force elements only) include: dummy, task force, and installation.

Command level and mobility.

Supplementary information about the role of the element in battle.

Preview window
Updates to show the symbol as you make changes to it in the editor. This one represents a friendly cavalry unit with armor.
When you add MOLE data to ArcMap or ArcGlobe, it is added as a MOLE group layer. A MOLE group layer has two sublayers and two types of Layer Properties dialog boxes, one for the ArcGIS feature layer portion of the group layer and one for the MOLE graphic portion.

To access either version, double-click on its corresponding layer in the ArcMap or ArcGlobe table of contents, as shown in the following illustration of the ArcMap table of contents.

In addition to the two types of layer properties dialog boxes described above, MOLE uses other types of layer properties dialog boxes based on underlying ArcGIS feature class type. The types of MOLE feature classes are:

- Force element—Based on the ArcGIS point feature class. Force elements are also known as force units, troops, or tactical symbols.
- Point tactical graphic—Based on the ArcGIS point feature class.
- Line tactical graphic—Based on the ArcGIS line feature class.
- Area tactical graphic—Based on the ArcGIS area feature class.

To determine whether a symbol is a point or a line, MOLE uses the number of points the military symbol specification says the symbol should have, as shown in the following table.

<table>
<thead>
<tr>
<th>If the military specification says the symbol should have</th>
<th>Then MOLE makes it a</th>
</tr>
</thead>
<tbody>
<tr>
<td>One point</td>
<td>Point feature.</td>
</tr>
<tr>
<td></td>
<td>If the symbol or its layer has a Parent field, MOLE considers it a force element/force element layer and uses the MOLE force element Layer Properties dialog box for it.</td>
</tr>
<tr>
<td>Two points</td>
<td>Line feature.</td>
</tr>
<tr>
<td></td>
<td>MOLE uses the MOLE line tactical graphic Layer Properties dialog box.</td>
</tr>
<tr>
<td>Three points</td>
<td>Area feature.</td>
</tr>
<tr>
<td></td>
<td>MOLE uses the MOLE area tactical graphic Layer Properties dialog box.</td>
</tr>
</tbody>
</table>

For more information, see Determining MOLE feature class type for new graphics in ArcGIS Desktop Help.
In This Chapter

- Exercise 1: Creating MOLE data using ArcCatalog
- Exercise 2: Working with force elements in ArcMap
- Exercise 3: Working with tactical graphics in ArcMap
- Exercise 4: Changing the 3D display type
- Exercise 5: Applying tracking to MOLE features

Using MOLE, you can display and edit MIL-STD-2525B Change 2 and APP-6A symbology on your ArcGIS maps. MOLE reads the 15-character Symbol ID code from a feature class’s attribute table and renders the proper military unit or tactical graphic at that feature’s geographic location.

This tutorial guides you through creating MOLE feature classes and populating them by drawing graphics in ArcMap. It also steps you through different ways you can work with MOLE graphics in ArcMap, ArcGlobe, and ArcGIS Tracking Analyst.

The data and maps required for these exercises are installed to `<ArcGIS installation directory>/MOLE/Tutorial` when you install MOLE. You can also access them on the ESRI Defense Solutions CD under the MOLE/Tutorial subdirectory.

For this tutorial, it is assumed that you have installed ArcGIS and MOLE, that you have a basic understanding of MIL-STD-2525B Change 2 or APP-6A, and that you are familiar with ArcGIS.
Exercise 1: Creating MOLE data using ArcCatalog

There are many ways to create MOLE data. For example, you can create an empty MOLE layer (or table) in ArcCatalog, then populate it the same way you populate any ArcGIS table, such as importing a spreadsheet or tabular data.

Another way to create MOLE data is to draw MOLE graphics on an ArcMap map, provided that you have first added a MOLE layer to the map and that you have the proper ArcEditor or ArcInfo license level.

In this exercise, you create an empty file geodatabase named Sitmap in your MOLE tutorial folder. Next, you add three of the four types of MOLE feature classes, then populate them by drawing graphics on a map.

1. Start ArcCatalog by clicking Start > Programs > ArcGIS > ArcCatalog.

2. In the ArcCatalog window, in the Catalog tree (left pane), do the following:
   - Navigate to the directory where you saved your MOLE tutorial data. You may have to first connect a folder to this location (in ArcCatalog, click File > Connect Folder).

   By default, MOLE installs your MOLE tutorial data to <ArcGIS installation directory>/MOLE/Tutorial.

   - Right-click the Data directory, then click New > File Geodatabase.

   An empty file geodatabase, New File Geodatabase.gdb, appears in the right pane of ArcCatalog.

3. Rename the new .gdb file by right-clicking it, then clicking Rename.

4. Type “sitmap” to indicate this geodatabase will contain data for a situation map, then press Enter.

   The new geodatabase you created appears in the right pane.
When you create a geodatabase, the three main types of data you can use to populate it are feature classes, raster datasets, and attributes. The feature class is a commonly used type; it can be used in the following structures: feature dataset, shapefile, coverage, CAD, SDC, and VPF.

MOLE functionality centers on the feature class. There are four types of MOLE feature classes (also known as layers), which reflect the four main types of MOLE graphics:

- Force element feature class (made up of ArcGIS point features)
- Point tactical graphic feature class (made up of ArcGIS point features)
- Line tactical graphic feature class (made up of ArcGIS line features)
- Area tactical graphic feature class (made up of ArcGIS area features)

Installing MOLE enables ArcCatalog to work with these MOLE feature classes and allows you to select them in the New Feature Class wizard in ArcCatalog. Although MOLE feature classes behave much like typical ArcGIS feature classes, they are custom ArcGIS feature classes because they contain fields specific to the military symbology specifications MOLE supports.

In the following steps, you create a MOLE force element feature class in the geodatabase you just created.

1. In ArcCatalog, right-click Sitmap.gdb, then click New > Feature Class.
   
   The first panel of the New Feature Class wizard appears.

2. In the Name text box, type “Allies”.

Create a MOLE force element feature class
3. In the Type area, click the drop-down menu, then click MOLE Force Element.

![New Feature Class window](image.png)

4. In the Geometry Properties area, check Coordinates include Z values, then click Next.

5. In the next panel of the wizard, in the Select a coordinate system area, expand Geographic Coordinate System, then navigate under that to World > WGS 1984.

6. Highlight WGS 1984, then click Next.

   The spatial reference of your data is now set.

7. In the next panel, in the list area, highlight None to specify that you don’t want to define a vertical coordinate system, then click Next.

8. In the next panel, click Next to accept the default XY tolerance setting.

9. In the next panel, accept the default by clicking Next. This setting indicates you want to use ArcGIS default storage settings for your feature class.

10. In the next panel, you can add fields and change field properties if you want. If you populate the fields here with values, MOLE uses the values as the default values for all new features (MOLE graphics) you add to this feature class.
11. Click Finish.

You have just created a MOLE file geodatabase that is populated with one empty force element feature class. The name of the feature class, Allies, displays in the Contents tab of the right pane of ArcCatalog. You can open this feature class in ArcMap or ArcGlobe.

You add the other types of MOLE feature classes to databases the same way you added the force element type in the previous steps. In the next steps, you will create a line tactical graphic feature class and an area tactical graphic feature class.

1. In ArcCatalog, right-click Sitmap.gdb, then click New > Feature Class.

The first panel of the New Feature Class wizard appears.

2. In the Name text box, type “My_arrows”.

3. In the Type area, click the drop-down menu, then click MOLE Tactical Graphic Line.

4. Follow steps 4 to 11 in the preceding set of steps to finish creating this line tactical graphic feature class.

5. Repeat steps 3 and 4 of this procedure to create an area tactical graphic feature.
The next step is to populate your new force element feature class with military symbols that adhere to a military specification you choose.

There are many ways to populate a feature class, but if you are populating it by drawing MOLE graphics in ArcMap, you will likely use the MOLE Symbol Editor. The MOLE Symbol Editor can simplify your graphic drawing task because it constructs the symbol for you and lets you preview it. You just have to tell MOLE which symbol to construct. There are many ways to do this. For example, you can click the symbol’s name in the Symbol Library tree or perform a search on its name using the search text box.

In the following set of steps, you start ArcMap, add a base layer for reference, add the MOLE toolbar, add the force element feature class you just created, then populate the feature class by drawing graphics on the map and using the MOLE Symbol Editor to refine them.

### Start ArcMap and add the MOLE toolbar

1. Start ArcMap by double-clicking a shortcut installed on your desktop or by clicking Start > Program Files > ArcGIS > ArcMap.
2. Click OK on the ArcMap startup dialog box to open an empty map.
3. In ArcMap, open the MOLE toolbar by right-clicking any ArcMap toolbar, then selecting Military Overlay Editor. You must have installed MOLE for this option to be available in the list of toolbars.

The MOLE toolbar appears. Most buttons on this toolbar won’t be available until you add MOLE data, but for illustration purposes, all are available in the following image:

Like ArcMap toolbars, you can choose to dock or float the toolbar by clicking and dragging it.

### Add a base layer

Before adding MOLE feature classes (MOLE layers) to a map, you should add a base layer or layers to use as a geographic reference. This exercise will have you use the tutorial data as your base layer.

1. Click the Add Data button on the ArcMap Standard toolbar.
2. In the Add Data dialog box, navigate to `<ArcGIS installation directory>/MOLE/Tutorial/Data`
3. Add Elevation.lyr.
The base layer named Elevation.lyr displays in the ArcMap map display. It should resemble the following illustration:

Add your newly created feature class to the map

1. In ArcMap, on the MOLE toolbar, click the Add MOLE Data button.
2. In the Add MOLE Layers dialog box, navigate to the feature class you created in the previous set of steps (the Allies feature class in sitmap.gdb), then add it to the map. You can also open a feature class that comes with the tutorial data, the FriendlyForces feature class, at `<ArcGIS installation directory>/MOLE/Tutorial/Data/OPLAN.gdb/MOLE`.

If you added Allies, the Select a Symbology Standard dialog box appears.

This dialog box appears any time MOLE encounters a layer for the first time. If you don’t want this dialog box to appear each time, you can specify that you want MOLE to mark layers automatically when it encounters them for the first time (on the MOLE toolbar, click MOLE > Options, then clear the Prompt, as needed, for standard check box).
Checking the Do not display this dialog again in the Select a Symbology Standard dialog box is the same as clearing the Prompt, as needed, for standard check box. If you choose to not be prompted, MOLE uses the specification you’ve selected in the Options dialog box each time it encounters an unmarked feature class.

3. Click MIL-STD-2525B Change 2, then click OK.

Because Allies is empty, the only change you should notice is that the Allies feature class is now in the ArcMap table of contents.

Note that each MOLE layer is actually a group layer composed of a simple ArcGIS feature layer (in this case, a point feature layer) and a MOLE graphic layer.

Now you are ready to populate the Allies feature class.

**Add military symbols to the MOLE layer**

1. If you haven’t already, add the ArcMap Editor toolbar to ArcMap by clicking the Editor toolbar button on the ArcMap Standard toolbar.

The Editor toolbar appears. Most of the items on the Editor toolbar are grayed out until you start an editing session.

2. Start an editing session by clicking Editor > Start Editing on the Editor toolbar.

More items on the Editor toolbar become enabled, as shown in the following illustration:
3. On the Editor toolbar, click the Task drop-down menu to select Create New Feature. Ensure Allies Features is selected as the target layer.

4. Click the Sketch button on the Editor toolbar.

5. Click in the map display to place a point in the middle of the current extent.

   The MOLE symbol for a force element with a pending affiliation and unknown threat type (yellow quatrefoil with a question mark) appears and is selected. Red is the default color used to surround a graphic to indicate the graphic is selected.

6. Click the MOLE Symbol Editor button on the MOLE toolbar.

   The MOLE Symbol Editor dialog box appears.

   ![MOLE Symbol Editor Dialog Box]

7. Expand the Symbol branch in the Symbol Library area, then expand Ground Track > Unit. Note the categories of symbols available for ground track units.
8. Type “Infantry” in the Search for box.
   Notice that only infantry units display in right-most branches in the Symbol Library.

9. Click the Affiliation drop-down menu and select Friend.

10. In the Symbol Library area, click to highlight Airborne. It’s under MIL-STD-2525B > Symbol > Unit > Combat > Infantry.
    Note that the symbol in the preview area of the MOLE Symbol Editor is updated to reflect the new symbol you selected, Airborne. The Symbol ID code at the bottom of the dialog box is also updated.

11. Click the Echelon/Mobility drop-down menu and click Division (you may have to use the scroll bar in the drop-down menu).

12. Click the Country drop-down menu and click United States (US).

13. Click the Order of Battle drop-down menu and click Ground.
The MOLE Symbol Editor should resemble the one in the following illustration:

14. Click OK.

The yellow quatrefoil graphic changes to the graphic you just built, as shown in the following illustration:

15. Repeat steps 4 to 14 to make another force element, but this time add it near the bottom of the extent and, in step 9, select Hostile in the Affiliation drop-down menu instead of Friend.

You can create more force elements by repeating steps 4 to 14.

16. If you’re continuing to the next section, skip this step. Otherwise, save the edits by clicking Editor > Save Edits on the Editor toolbar and save the map by clicking File > Save in the Main menu. Name the map EX_1.mxd.
Unlike force elements, which are always points, tactical graphics can be constructed as points, lines, or polygons in ArcMap, making them a bit more complex. For example, certain tactical graphics, such as arrows, require certain drawing logic for MOLE to properly render them according to the military specification you are using. The military specifications are very specific in how a tactical graphic is constructed. MOLE follows that logic as closely as possible. As you become more familiar with the specifications and the MOLE built-in logic, drawing tactical graphics will become easier for you.

In the following steps, you open tactical graphic feature classes in ArcMap and draw MOLE symbols in them.

**Draw a multipoint arrow**

1. If you are continuing from the previous exercise, skip this step. Otherwise, open ArcMap, turn on the Editor toolbar, and open the map named EX_1.mxd that you saved in the last steps.

2. Add the line tactical graphic feature class named My_arrows, which is in the geodatabase, Sitmap.gdb, you created in a previous set of steps. Be sure to use the Add MOLE Data button to add it. When prompted, use the MIL-STD 2525B Change 2 symbology standard.

3. On the Editor toolbar in ArcMap, click the Target drop-down menu and click My_arrows Features. Make sure that an edit session is running, and the Create New Feature option is selected in the Task drop-down menu on the Editor toolbar.

4. Click the Sketch button on the Editor toolbar if it is not already selected.

   The mouse pointer changes to crosshairs.

5. Click in the map display area to place the first vertex of the line to the left of the force element symbol you created earlier.
6. Continue placing vertices, about four or five more, until you add the next-to-last one near the border of the hostile force element symbol. When finished, your map display should resemble the following image:

![Map Display Example](image)

Now you are ready to create the arrowhead and finish adding the arrow. You create the arrowhead when you add the last vertex. The placement of the last vertex determines the size and shape of the arrowhead.

7. Click in the display to add the last vertex, as shown in the following illustration. You must follow two rules when adding the last vertex. The line segment you create when you add the last vertex

- Must form an acute angle with the previous line segment
- Must not extend beyond the previous line segment

Note that ArcMap will not notify you if the last vertex is invalid as you place it. If the line does not satisfy the renderer’s criteria, MOLE will notify you in the symbol selector, and the completed line will display as a curved magenta line.

![Vertex Placement Rules](image)
8. To complete the tactical graphic, double-click, press F2, or right-click and click Finish Sketch.

The graphic is red because it is in the selected state, which is how you want it for the next step.

9. Specify that you want this graphic to be a main arrow of attack:
   a. Click the MOLE Symbol Editor button on the MOLE toolbar.
   b. In the MOLE Symbol Editor, in the Symbol Library area, navigate to Command & Control and General Maneuver > Offense > Lines > Axis of Advance. Next, click to highlight Main Attack, then click OK.

   In the map display, the graphic changes to a red main attack arrow (red because it is still selected).

10. Deselect the arrow by clicking the Clear Selected Features button in the Tools toolbar.

    The MOLE graphic should now resemble the following illustration:

    ![MOLE graphic](image)

10. Continue to the next exercise, or close ArcMap without saving changes.
Exercise 2: Working with force elements in ArcMap

Open the tutorial data

Most of the common MOLE operations are standard ArcMap procedures and commands. MOLE acts as a special renderer that allows ArcMap to conform to the MIL-STD-2525B Change 2 or APP-6A specification. In this exercise, you open a base layer, add one of each type of MOLE feature class to make a situational awareness map, then resize and leader force elements.

1. Open an empty map in ArcMap, then click the Add Data button on the ArcMap Standard toolbar.

2. In the Add Data dialog box, navigate to <ArcGIS installation directory>/MOLE/Tutorial/Data.

3. Double-click Elevation.lyr.

   The base layer named Elevation.lyr displays in the ArcMap map display, and you are ready to add MOLE feature classes.

4. In ArcMap, on the MOLE toolbar, click the Add MOLE Data button . You must use this button to add MOLE feature classes if you want the feature classes to be rendered with military symbology.

5. In the Add MOLE Layers dialog box, navigate to <ArcGIS installation directory>/MOLE/Tutorial/Data/OPLAN.gdb/MOLE.

6. Press the Ctrl key while you click to highlight the following MOLE feature classes: FriendlyForces, TacticalAreas, TacticalLines, and TacticalPoints.

7. Click OK. The map display should appear similar to the following image:
Your map now contains one of each type of MOLE feature class:

- A force element feature class
- A point tactical graphic feature class
- A line tactical graphic feature class
- An area tactical graphic feature class

1. In the ArcMap table of contents, clear the check boxes for all of the group layers except FriendlyForces and Elevation.

The table of contents and display should resemble those in the following image:

![Map display showing MOLE features](image)

2. Add another force element layer. Click the Add MOLE Data button on the MOLE toolbar, then navigate to `<ArcGIS installation directory>/MOLE/Tutorial/Data/OPLAN.gdb/MOLE. Add EnemyForces.

Notice that the enemy force symbols are a different color and are smaller than the friendly force symbols. They also have a different frame shape. The color and frame shape differences are based on the descriptions in MIL-STD-2525B Change 2 and APP-6A. In the following steps, you will change the size of the enemy force symbols to match the friendly force symbols.

3. In the ArcMap table of contents, click the EnemyForces group layer to highlight it.

4. On the MOLE toolbar, click the Graphic Height button ![Graphic Height button](image)

   The mouse pointer changes to crosshairs with a box.

5. Click and drag in the map display to draw a box whose height is about the same size as the height of the friendly force symbols. You can draw the box beside one of the force elements to make it easier to estimate a similar height.
The symbols in the EnemyForces layer increase in size. Their height matches the height of the box you drew.

The map display should appear similar to the following image:

6. Next you will use the toolbar to reduce the size of the graphics in two layers in the data frame. Press and hold the Ctrl key and click to highlight the EnemyForces and the FriendlyForces group layers in the table of contents, as shown in the following image:

7. Make sure the Graphic Height button is selected and draw another box, but this time, make the height of the box you draw about half the size of one of the force elements.

All of the graphics in the two layers you highlighted decrease in size.

Next, you will use the toolbar to increase the size of all MOLE graphics of the same type (force element or tactical graphic) in the data frame.

8. Click the white space under the layers list in the table of contents. This removes the highlighting of the layers you selected in step 6, but it has the same effect as step 6, because all layers is the default selection behavior for MOLE toolbar buttons when no layers are highlighted in the table of contents. You can therefore apply MOLE toolbar functions to all MOLE graphics in the data frame by clicking white space in the table of contents below the layers before using the toolbar.
9. To illustrate this behavior, on the MOLE toolbar, click the Graphic Height button, then click and drag a box in the map display to draw a box that is about twice the height of the graphics in the display.

All graphics in the data frame (and map display) increase in size to about twice the height they had before.

You can resize graphics in a layer more precisely using the Symbols tab of the MOLE Layer Properties dialog box, as is demonstrated in the next set of steps.

Note that this affects the TacticalPoints and TacticalLines layers, even though they are not displayed. It does not affect TacticalAreas, because the Graphic Height button only affects graphics rendered by MOLE, not spatial data.

Many of the functions in the MOLE Layer Properties dialog box are also on the MOLE toolbar. The main difference between these corresponding functions is that the ones on the toolbar allow you to apply changes to all layers or selected layers, while the Layer Properties dialog box allows you to apply changes to only one layer at a time. For some MOLE toolbar buttons, the layers affected will all be of the same type, either force element or tactical graphic. For example, the leadering buttons affect only force element layers.

In the next steps, you will resize, then stack, MOLE graphics using the Layer Properties dialog box.

**Resize force elements using the Layer Properties dialog box**

1. If you are continuing from the previous steps, repeat steps 9 and 10, but this time, in step 10, draw a box that’s a quarter of the height of the current graphics in the display to make the map more readable.

   If you are not continuing from the previous step, open a blank map and add the FriendlyForces and EnemyForces feature classes in `<ArcGIS installation directory>/MOLE/Tutorial/Data/OPLAN.gdb/MOLE`.

2. In the ArcMap table of contents, double-click the MOLE graphic layer of the FriendlyForces group layer.

   ![Layers](image)

   The MOLE Layer Properties dialog box for force elements appears.

3. Click the Symbols tab.
4. On the Symbols tab, in the Size area, in the Friendly Frame text box, replace the existing value with .07.

5. Make sure you also have Map selected in the Size area and click OK. The Map setting indicates that you want the units of the value in the adjacent text box to be map units, which are the units of measure for the layer established by the layer’s coordinate system. For example, if the coordinate system is WGS_1984 and Map is selected, a value of 1 in the adjacent text box will make the force elements 1 degree of latitude in height. For details about the different methods you can use to set MOLE graphic size, see Editing MOLE graphics from within ArcMap in ArcGIS Desktop Help.

The MOLE graphics in the FriendlyForces layer are once again bigger than those in the EnemyForces layer, as shown in the following illustration:
Stack force elements using the Layer Properties dialog box

1. In the ArcMap table of contents, double-click the FriendlyForces group layer of the MOLE graphic layer.

2. In the Layer Properties dialog box, click the Stacking tab, then check the Enable Stacking check box.

3. In the Stacking Rules list area, clear the check boxes of all rules except the Proximity rule. Click Proximity Rule to highlight it.

   In the Rule Properties area, the property names appear to reflect the Proximity rule.

4. In the Values column to the right of the Tolerance property name, highlight the existing value (by default, this is 0) to enable the value for editing.

5. Type “.15” in the Values column to indicate you want MOLE to group force element graphics that are within .15 map unit of each other. Press Enter, then click OK. You may have to click the Toggle Stacking button on the MOLE toolbar.
All force element graphics in the map that satisfy the .15 distance you set for this layer are grouped onto stacks in the map display, as shown in the following image:

If you repeat this procedure for additional layers, when you toggle stacking on, the map display will show stacking for all layers selected in the table of contents. Stacking honors the rules for each individual layer, so the rules can be different for each layer.

6. It is not necessary to save the changes to this map to continue to the next exercise.
Exercise 3: Working with tactical graphics in ArcMap

Working with tactical graphics is similar to working with force elements. Examples of two noteworthy differences—that tactical graphics come with renderers you can enable and that text size and graphic size are independent of each other—are provided in the steps in this exercise.

Every type of tactical graphic corresponds to at least one MOLE tactical graphic renderer. A tactical graphic will not display if one of its associated renderers is not enabled. By default, all renderers are enabled, but if you are working with only one type of tactical graphic and are using MIL-STD-2525B Change 2, you can turn off all other renderers to improve performance. You can also turn off renderers or change their order of priority to change the appearance of a tactical graphic layer.

1. Open OPLAN.mxd from the tutorial dataset in <ArcGIS installation directory>/MOLE/Tutorial.

2. From the Main menu in ArcMap, click Bookmarks > Swoopy Arrow to navigate to the supporting attack arrow in the upper right portion of the dataset. Your view should look similar to the following image:

3. In the table of contents, turn off all the group layers except the TacticalLines group layer and the Elevation group layer.

4. In the table of contents, double-click the TacticalLines Graphics layer to open the MOLE Layer Properties dialog box. Move the Layer Properties dialog box so that you can still see the arrow in the map display.

5. In the Layer Properties dialog box, click the Renderers tab.

6. In the Renderers tab, in the Available Compatible Renderers list area, click Swoopy Arrows. You may have to scroll down to see Swoopy Arrows. The right-pointing arrow becomes available.
7. Click the right-pointing arrow.
   The Swoopy Arrows renderer now appears in the Associated Renderers list area and the up-pointing arrow becomes available.

8. Click the up-pointing arrow to move the Swoopy Arrows renderer above the All Tactical Graphics renderer.

9. Click OK.
   Your map should appear similar to the following image:

   ![Map Display with Swoopy Arrows](image)

   The arrow in the map display changes from a rectilinear (angular) arrow to a swoopy (rounded) arrow. This is because, by default, the Swoopy Arrows renderer does not take priority over the default rectilinear arrow renderer. By positioning the Swoopy Arrows renderer above the All Tactical Graphics renderer in the Associated Renderers list area in step 8, you specified that you wanted MOLE to use the Swoopy Arrows renderer on applicable graphics.

10. To prepare for future exercise steps, check the check boxes of all layers in the table of contents, then click the Full Extent button on the Tools toolbar. Next, save the .mxd to `<ArcGIS installation directory>/MOLE/Tutorial` and name it OPLAN_TacticalGraphics.mxd.
Text and graphic size for tactical graphics are adjusted independently of each other. As with force elements, changes can be made at the layer level through the MOLE Layer Properties dialog box pages or for selected or all layers in the table of contents through the tools on the MOLE toolbar.

1. If it’s not already open, open the OPLAN_TacticalGraphics.mxd you saved from the previous exercise.

2. From the Main menu in ArcMap, click Bookmarks > Air Corridor to zoom to one of the air corridor tactical line graphics.

3. In the table of contents, turn off all the group layers except the TacticalLines group layer, the TacticalPoints group layer, and the Elevation layer. Your view should look similar to the following image:

4. Click the TacticalLines Graphics layer in the table of contents to highlight it and activate the MOLE toolbar.

5. On the MOLE toolbar, click the Graphic Height button.

   The mouse pointer turns into a crosshairs symbol.

6. Click and drag the smallest box you can in the map.
When you release the mouse, the space between the lines within each air corridor decreases, narrowing the air corridors, as shown in the following image:

7. Save the .mxd to <ArcGIS installation directory>/MOLE/Tutorial/OPLAN_TacticalGraphics.mxd.
Exercise 4: Changing the 3D display type

In the following exercise, you will use the Graphic Height tool on the MOLE toolbar to adjust the size of the billboarded force elements that come with the tutorial dataset. You will also use the Layer Properties dialog box to preview three 3D display types, then apply the drape and billboard display type.

1. Open ArcGlobe by clicking Start > Programs > ArcGIS > ArcGlobe. Your ArcGlobe window should appear similar to the following image:

![ArcGlobe window](image)

2. In ArcGlobe, add Digital Elevation Model (DEM) data by clicking the Add Data button on the Standard toolbar and navigating to <ArcGIS installation directory>/MOLE/Tutorial/Data. Click to highlight dem.img, then click Add.

3. In the Add Data Wizard, click Use this layer as elevation source, then click Finish.

4. Add the MOLE toolbar by right-clicking any ArcGlobe toolbar, then selecting Military Overlay Editor.

   The MOLE toolbar for ArcGlobe appears. Not all of its buttons will be available.

![MOLE toolbar](image)

5. On the MOLE toolbar, click the Add MOLE Data button.

6. In the Add MOLE Layers dialog box, navigate to <ArcGIS installation directory>/MOLE/Tutorial/Data/OPLAN.gdb.

7. In OPLAN.gdb, open the MOLE dataset, then highlight to select the feature classes named FriendlyForces and EnemyForces.

8. Click Add.

   In the map display, the friendly forces layer displays with blue graphics, and
the enemy forces layer displays with red graphics that are smaller than the blue graphics.

9. Click and drag the mouse pointer upward in the map display. If this action pans the map instead of tilting it, click the Navigation Mode button on the ArcGlobe Tools toolbar, , then click and drag the mouse pointer upward in the map display. The map in the map display begins to tilt so that you can better see the 3D aspects of the environment.

Tip: If you clicked other ArcGlobe tools before step 9, you may also have to click the Navigation Mode button before you can tilt the map.

10. Repeatedly click and drag the mouse pointer upward in the map display until you’ve tilted the map to an oblique pitch angle similar to the one in the following illustration:

1. At the bottom of the ArcGlobe table of contents, click the Display tab. This step makes available the rest of the tools on the MOLE toolbar. Then click the FriendlyForces element layer to select it.

2. Press and hold the Ctrl key, then click the EnemyForces element layer.

Both the FriendlyForces and EnemyForces layers should be selected in the table of contents.

3. On the MOLE toolbar, click the Graphic Height button.

The mouse pointer changes to crosshairs with a box.

4. In the ArcGlobe map display, click and drag a box whose height is about
one-quarter of the force element graphics’ height.

The height of both the friendly and enemy force elements changes to match the height of the box you drew. MOLE determines graphic size based on height in this case. As shown in the following image, the friendly force elements decrease significantly in size and the enemy force elements increase only slightly in size:

You have several options for displaying MOLE graphics in 3D. A few examples are illustrated here. The following images illustrate the three options for displaying force elements in 3D:

In the following exercise, you preview three 3D display types, then apply the drape and billboard display type to a MOLE force element layer.

1. In the ArcGlobe table of contents, double-click the MOLE graphic layer of the FriendlyForces group layer.
2. In the MOLE Layer Properties dialog box, click the 3D Display tab.
3. Click the different display type options and view the preview of them in the 3D Display tab: Drape, Billboard, and Drape and Billboard.

4. When you are finished viewing the options in the preview window, click Drape and Billboard, then click OK. MOLE applies the display type you chose. Your map display should resemble the following image:
Exercise 5: Applying tracking to MOLE features

In this exercise, you use the ArcGIS Tracking Analyst extension and a feature class with temporal data to display tracking data symbolized by MOLE. Unlike MOLE, Tracking Analyst is an extension that requires an extension license.

1. If you haven’t already, install ArcGIS Tracking Analyst.
2. If you haven’t already, connect a folder to the sample data used in MOLE tutorial exercises. In ArcCatalog, click File > Connect Folder, navigate to <ArcGIS installation directory>/MOLE/Tutorial, then click OK.
4. Turn on the Tracking Analyst toolbar by right-clicking on any ArcMap toolbar, then clicking Tracking Analyst.

The Tracking Analyst toolbar appears. Note that the image below shows the right-most button, the Step Through Tracks button, as being available. However, it will not be available until you have added an event.

5. On the Tracking Analyst toolbar, click the Add Data button.

The Add Temporal Data Wizard appears.

6. In the first panel of the wizard, do the following:
   - In the first step, click a feature class or shapefile containing temporal data.
   - In the second step, click the Browse button and navigate to <ArcGIS Installation Directory>/MOLE/Tutorial/Data/ MOLE_TRACKING.gdb.
Add the CARGO_AIRLIFT feature class.

- Values for the third and fourth steps appear by default in this exercise, but if your fields were named differently, you would probably have to specify which fields contained your date/time information and your track identification value.
- Click Next.

7. In the second panel of the wizard, click Finish to accept the default settings.

The ArcMap map display shows the CARGO_AIRLIFT feature class. It is not yet symbolized by MOLE.

In the next steps, you will apply MOLE symbology to this feature class.

8. Right-click the CARGO_AIRLIFT layer in the ArcMap table of contents, then click Properties.

The Layer Properties dialog box appears.

9. Click the Symbology tab.
10. In the Show area, click to highlight Events. In the Drawn As area, highlight MOLE (2525B). You may have to scroll up in the Drawn As area.

11. In the 2525B Event Renderer Configuration area, in the Military Descriptor Column Name drop-down menu, click Symbol_ID, then click OK.

   The ArcMap map display shows the CARGO_AIRLIFT layer rendered with MOLE symbology.
In this next set of steps, you will add more layers, then track the MOLE features you add. First, you will add some more layers.

1. Repeat steps 5 through 11 in the previous set of steps for the SPECIAL_OPERATIONS_FORCES and TANKER feature classes in the MOLETRACKING.gdb database.

When you’ve finished, the ArcMap map display should appear similar to the following image:

2. Click the Playback Manager button on the Tracking Analyst toolbar.

3. In this step, you will ensure that the full time frame of the data will be displayed. In the Playback Manager dialog box, choose the earliest time available for start time (in the Start drop-down menu) and the latest time available for end time (in the End drop-down menu). For this sample data, the earliest start time is 8/30/1998 6:00 a.m. and the latest end time is 8/30/1998 8:04 a.m.

4. Click the Options button to display additional settings in the Playback Manager dialog box. The Playback Manager dialog box should resemble the image below:

5. In the Set the playback rate area, set the playback rate to 1 minute per second by typing “1” in the text box and selecting Minutes from the drop-down menu.
6. Press the Play button. The MOLE symbols move around the map display as each time event occurs. In this case, every time the symbols move (once per second) represents a minute.

7. Press the Stop button, then click and drag the red slider control in the graphic area of the Playback Manager dialog box. Notice that as you move the slider control left and right in the graphic area, the map display changes to reflect the location of the MOLE graphics at the place in time where the red slider bar is resting.
In This Chapter

• Additional system requirements for developers
• What you get in the Defense Solutions SDK
• Migrating your Military Analyst and MOLE applications to the Defense Solutions library

The Defense Solutions software development kit (SDK) consists of:

• Two main application programming interfaces (APIs), the Military Analyst API and the MOLE API
• Application samples
• Documentation

The above collection enables developers to build applications that provide military symbology, coordinate conversion, creation of geodetically correct geometries, and other defense analysis tools. The Defense Solutions API is available through the Defense Solutions library, which combines two distinct libraries from previous releases of ArcGIS--the Military Overlay Editor (MOLE) library and the Military Analyst library.

You must install either Military Analyst or MOLE to use the Defense Solutions library and SDK documentation, such as library overviews, the library reference, how-to samples, and conceptual articles. See the topic Migrating your Military Analyst and MOLE applications to the Defense Solutions library in this chapter for details on how to update your existing MOLE and Military Analyst applications to use the Defense Solutions library.
Additional system requirements for developers

The SDK is available for the following platforms and programming languages:

- Windows: C#, Visual Basic .NET, Java, Visual C++, cross-platform C++
- Linux: cross-platform C++, Java

The Defense Solutions SDK has the same system requirements (hardware and software requirements) as the ArcGIS developer framework you’re using. To view these system requirements, do the following:

1. In your Web browser, go to http://support.esri.com.
2. Click Knowledge Base, then click System Requirements.
3. Follow the on-screen instructions to view information on the ArcGIS development framework you intend to use (ArcGIS Engine, ArcGIS Server, or ArcGIS Desktop) and your environment, such as your operating system.

Note that to use Military Analyst and MOLE with ArcGIS Server (to serve map documents), you must install Military Analyst or MOLE on the same machine as ArcGIS Server.

4. If you are developing with MOLE on a Linux system and do not have access to an installation of MOLE on Windows, you can view the help that comes with MOLE on Windows by opening the MOLE Web-based help area of the ESRI Knowledge base at:

http://support.esri.com/index.cfm?fa=knowledgeBase.gateway. The help that comes with MOLE on Windows provides information such as detailed field descriptions for the MOLE schema, a description of how MOLE determines a military symbol’s shape based on the military specification you are using, and so on.

What you get in the Defense Solutions SDK

The SDK provides the following features to support developers:

- Military Analyst and MOLE APIs—includes object libraries, Java jars, and C++ header files.
- Developer documentation—includes the library overview, library reference, conceptual articles, and object model diagrams (OMDs).
- Samples—includes standalone sample applications and code snippets.

The SDK is available for the following platforms and programming languages:

- Windows: C#, Visual Basic .NET, Java, Visual C++, cross-platform C++
- Linux: cross-platform C++, Java

Each API consists of the object libraries, Java jars, and C++ header files that are installed to your ArcGIS installation folder when you install Military Analyst and MOLE. The following sections, divided by programming language, provide the steps you must perform for each language or platform in order to access the Defense Solutions library.
Installing and Getting Started with Defense Solutions

**.NET**

**C#**

1. On the Visual Studio .NET Solution Explorer pane, right-click on the References node, and click Add Reference.
2. On the Add Reference dialog’s .NET tab, select ESRI.ArcGIS.DefenseSolutions and click OK.

**Visual Basic .NET**

2. On the Add Reference dialog’s .NET tab, select ESRI.ArcGIS.DefenseSolutions and click OK.

**Java**

If you are using Eclipse, see the topic *How to install ArcGIS plug-ins* in the ArcGIS Engine Java Help under ArcGIS Engine > Using IDEs > Eclipse. In this case, the Defense Solutions library is included in the ArcGIS Engine Eclipse plug-in installation. If you are using a different IDE, follow the instructions specific to your IDE on how to add references to your project. In addition, you will need to add the following import statement to your source file:

```java
import com.esri.arcgis.defensesolutions.*;
```

**Visual C++**

For Visual C++, add an import statement for esriDefenseSolutions.olb to your project header file. For example:

```cpp
#import "/Program Files/ArcGIS/com/esriDefenseSolutions.olb"
```

**Cross-platform C++ (UNIX)**

1. In the project Make file, in all instances where the flag `-larcsdk` is present, also add the flag `-ldefensesolutionssdk`
2. In the project source code, in all instances where the statement
   ```cpp
   #include <ArcSDK.h>
   ```
   is present, also add the statement
   ```cpp
   #include <esridefensesolutions.h>
   ```
3. In the project source code, all instances of the statement
   ```cpp
   ::AoInitialize(NULL) must be followed by the statement
   ::DsInitialize()
   ```
Developer help for Military Analyst and MOLE APIs provides the same types of documentation that ArcGIS provides, such as the library overview, library reference, conceptual articles, object model diagrams (OMDs), how-to topics, and sample documentation. You can open developer help for each SDK as follows:

**.NET (C#, Visual Basic .NET)**

Click Start > All Programs > ArcGIS > Developer Help > Engine Help for .NET (VS2005) > Building solutions with ArcGIS Engine using .NET, then:

- To view conceptual articles, sample documentation, how-to topics:
  
  Click Working with ArcGIS components > Other ArcGIS Engine Runtime extensions > Defense Solutions: Military Analyst and Military Overlay Editor.

- To access the library reference, click ArcObjects library reference > DefenseSolutions.

- To view the main object model diagram, click ArcObjects library reference > DefenseSolutions. Then, on the DefenseSolutions library overview page, click the object model diagram link next to the heading *Additional library information*.

- To view the geoprocessing tool reference:
  
  - For Military Analyst, click Working with ArcGIS components > Geoprocessing > Tool reference > Military Analyst toolbox.
  
  - For MOLE, click Working with ArcGIS components > Geoprocessing > Tool reference > Military Overlay Editor toolbox.

**Java**

**Windows**

Click Start > All Programs > ArcGIS > Developer Help > Open Java Help, then click ArcGIS Engine > ArcObjects Developer Guide > Defense Solutions: Military Analyst and MOLE. Next:

- To view sample documentation, click ArcGIS Engine > Samples > DefenseSolutions.

- To access the library reference, click ArcGIS Engine > Reference > Library References > Defense Solutions.

- To view Javadoc (fine-grained descriptions of API items), click ArcGIS Engine > Reference > Defense Solutions Javadoc.

- To view the main object model diagram, click ArcGIS Engine > Reference > Library Reference > Defense Solutions. On the DefenseSolutions library overview page, click the object model diagram link next to the heading *Additional library information*.

**Visual C++**

Click Start > All Programs > ArcGIS > Developer Help > Engine and Desktop Help for C++ (VS 2005), then:

- To view documentation for samples, click Building solutions with ArcGIS Engine using Visual C++ > Walkthroughs and samples > VCPP Samples > DefenseSolutions.
• To view the library reference, click Building solutions with ArcGIS Engine using Visual C++ > ArcObjects library reference > DefenseSolutions.

• To view the main object model diagram, open the file DefenseSolutionsObjectModel.pdf in <ArcGIS installation directory>/ArcGIS/DeveloperKit/Diagrams.

• To view the geoprocessing tool reference:
  - For Military Analyst, click Working with the ArcGIS platform > Geoprocessing in ArcGIS > Tool reference > Military Analyst toolbox.
  - For MOLE, click Working with the ArcGIS platform > Geoprocessing in ArcGIS > Tool reference > Military Overlay Editor toolbox.

**Cross-platform C++ (Linux/Windows)**

1. On Linux or Solaris, from the command line, go to your ArcGIS installation directory and type `viewCppHelp`. On Windows, go to Start > All Programs > ArcGIS > Developer Help > Engine and Desktop Help for C++.

2. Sample documentation - click Building solutions with ArcGIS Engine using C++ > Samples and scenarios > Samples > DefenseSolutions.


4. Geoprocessing Tool Reference

  • Military Analyst - click Building solutions with ArcGIS Engine using C++ > Working with the ArcGIS Platform > Geoprocessing > Tool reference > Military Analyst toolbox

  • Military Overlay Editor - click on Building solutions with ArcGIS Engine using C++ > Working with the ArcGIS Platform > Geoprocessing > Tool reference > Military Overlay Editor toolbox

Stand-alone samples that demonstrate the use of the Defense Solutions API are included in the SDK. How to’s and snippets provide source code that can be directly copied into your project. Documentation for the samples is provided both in the developer help as discussed in the previous section, and in Readme.htm files found in each sample’s project folder. You can find the samples in the following locations:

**NET (C#, Visual Basic .NET)**

C# and VB.NET samples are located in <ArcGIS installation folder>/DeveloperKit/SamplesNET. Military Analyst samples are in folders having names that start with “MA”. MOLE samples are in folders having names that start with “MOLE”. You can open the sample by double-clicking on the desired .sln file. Each sample folder contains a Readme.htm file that describes the sample and how to use it.

**.NET snippets**

ArcGIS sample code snippets are integrated with Visual Studio .NET. To insert a code snippet directly into your C# or VB.NET project, determine the location where you want to insert the code snippet, right-click, and select Insert Snippet > ArcGIS Engine > Extensions > Military Analyst or Military Overlay Editor > the desired code snippet.
Developing with Defense Solutions

Implications for 9.3, 9.3.1, 10, and future development

Samples

Java
Samples are located in `<ArcGIS installation folder>\java\samples\engine`. Defense Solutions samples are located in folders having names that start with DefenseSolutions (for example, DefenseSolutions.MOLE.Stacking). If you are using Eclipse, you can import the sample using the File > Import menu.

Visual C++
Samples are located in `<ArcGIS installation folder>\DeveloperKit\SamplesCOM\DefenseSolutions`. The folder names indicate that the sample is written in Visual C++. Open the sample in Visual Studio by double clicking on the desired .sln file.

Cross-platform C++ (Linux/Windows)
On Linux, sample code projects are located in `<ArcGIS installation directory>/DeveloperKit/Samples/CPP/DefenseSolutions`. On Windows, code samples are located in `<ArcGIS installation folder>/DeveloperKit/Samples/CPP/DefenseSolutions`. For a few of the samples, the zip file name indicates which framework or toolkit is used with the sample (Qt, GTK, or Motif). Otherwise, the sample is a console application that is invoked from the command line.

Visual Studio .NET Code Snippets
This feature, available only in the ArcGIS Engine SDK for .NET, allows developers to insert pre-made Military Analyst and MOLE C# and VB.NET code snippets directly into their C# and VB.NET projects from within Visual Studio. This feature saves developers time and effort by providing pre-made code for frequently used workflows. For details, see the topic Snippets for ArcGIS .NET developers in the document ArcGIS Engine Help for .NET under Building solutions with ArcGIS Engine using .NET > Visual Studio Integration Tools > Overview... > ArcGIS Snippets.

Migrating your Military Analyst and MOLE applications to the Defense Solutions library

The Defense Solutions library (esriDefenseSolutions.olb), new at ArcGIS version 9.3 (and which therefore also characterizes 9.3.1, 9.3.1 SP1, and 10), merges two distinct libraries from previous releases of ArcGIS—the Military Analyst library and the MOLE library. As a result, you may need to make some changes to your existing ArcObjects applications. This document describes the reasons for this change and the steps you need to take to update your existing Military Analyst and MOLE applications to use the new Defense Solutions library.

At Versions 9.2 and earlier, the MOLE type library was available as esriMOLE.olb. Military Analyst also provided an API at version 9.2—esriMilitaryAnalyst.olb. To provide a unified experience for developers who currently use both libraries, at version 9.3, these two libraries were combined into one single type library, DefenseSolutions (esriDefenseSolutions.olb). This means that, in order to gain access to both the Military Analyst and MOLE APIs, you can now add a reference to the ESRI Defense Solutions Object Library (esriDefenseSolutions.olb). Subsequently, while coding, you can declare types defined in the DefenseSolutions library, for example:
When should you make the code changes?

Many deployed applications and customizations will continue to work against 10 (and 9.3.1 and 9.3.1 SP1) because the GUIDs for the MilitaryAnalyst and MOLE classes and interfaces did not change between 9.2 and 9.3. However, it is recommended that you recompile and redeploy all source code for version 10 (or 9.3.1 SP1 if that’s where you are starting) because there are some scenarios wherein existing deployments will fail:

- Any software that uses ProgID strings (see the ProgID example below) will need to be changed to use the new library name. If such code exists in a compiled component, it will need to be modified and redeployed to work with the DefenseSolutions library.
- VBA deployments will fail if they contain any references to esriMOLE or esriMilitaryAnalyst in code.

What do you need to do?

- For new development, you will need to add a reference to a single type library, DefenseSolutions. For .NET development, the full assembly name is ESRI.ArcGIS.DefenseSolutions. Do not add references to Military Analyst or MOLE.
- In existing source code, you must change any explicit use of the type library names esriMOLE or esriMilitaryAnalyst to esriDefenseSolutions. This includes the following cases (declarations, instantiations, implementations, and ProgIDs):

  **Declarations (including parameters in procedures)**

  **VB.NET**
  ```vbnet
  Dim pCG As esriMOLE.ICachedGraphic >>>
  Dim pCG As esriDefenseSolutions.ICachedGraphic
  Dim pCT As esriMilitaryAnalyst.ICoordinateTool >>>
  Dim pCT As esriDefenseSolutions.ICoordinateTool
  ```

  **C#**
  ```csharp
  ESRI.ArcGIS.MOLE.ICachedGraphic cg >>>
  ESRI.ArcGIS.DefenseSolutions.ICachedGraphic cg
  ESRI.ArcGIS.MilitaryAnalyst.ICoordinateTool ct >>>
  ESRI.ArcGIS.DefenseSolutions.ICoordinateTool ct
  ```

  **Instantiations**

  **VB.NET**
  ```vbnet
  Set pCT = New esriMilitaryAnalyst.CoordinateTool >>>
  Set pCT = New esriDefenseSolutions.CoordinateTool
  ```

  **C#**
  ```csharp
  pCT = new ESRI.ArcGIS.MilitaryAnalyst.CoordinateToolClass() >>>
  pCT = new ESRI.ArcGIS.DefenseSolutions.CoordinateToolClass()
  ```
Developing with Defense Solutions

Implementations

**VB.NET**

Implements esriMOLE.ILeaderingRule >>>
Implements esriDefenseSolutions.ILeaderingRule

**C#**

public class MyLeaderRule: esriMOLE.ILeaderingRule >>>
public class MyLeaderRule: esriDefenseSolutions.ILeaderingRule

ProgIDs (the text alias for a CLSID)

**VB.NET**

Dim pUID As New UID
pUID.Value = "esriMOLE.ForceElement2525BRenderer“ >>>
pUID.Value = "esriDefenseSolutions.ForceElement2525BRenderer”

**C#**

UID myUID = new UID();
myUID.Value = "esriMOLE.ForceElement2525BRenderer“ >>>
myUID.Value = "esriDefenseSolutions.ForceElement2525BRenderer”

Note: Implementations that use CLSIDs will not be affected (the CLSIDs have not changed for version 9.3.1, 9.3.1 SP1, or 10), and no code changes are necessary. For example, the following code will continue to work between 8.x and 9.0:

**VB.NET**

Dim pUID As New UID
pUID.Value = "{24BC0FB5-8D3A-4133-846A-671DD5C01A81}“

**C#**

UID myUID = new UID();
myUID.Value = "{24BC0FB5-8D3A-4133-846A-671DD5C01A81}“;
Index

A
Acrobat 8.0  15
administrator privileges  26
antitank obstacles  17
API. See Defense Solutions SDK
ArcGIS Desktop Help, how to access  6
ArcGIS Server
  using with MOLE  30
ArcGIS Web Help, how to access  6
ArcGlobe
  basics for using with MOLE  30
  Fly Through tool (Military Analyst)  52
  installing  25
  Military Analyst toolbar buttons illustrated  47
  MOLE toolbar described  54
  Threat Dome tool (Military Analyst)  52
ArcSDE
  using with MOLE  30
ArcView
  creating MOLE feature classes with  38
  restrictions with MOLE  21
Attribute Editor. See MOLE Symbol Editor
C
comparison
  geodatabase vs. shapefile  37
contacting ESRI  7
context sensitive help  15
context-sensitive help, how to access  6
Convert Coordinate in File  17
cross platform  
C++  94
  installing on  22–26
  Linux  7, 22
  Solaris  22
D
data
  creating and loading (Military Analyst and MOLE)  
    38
  creating MOLE data  37
  tutorial exercise  59–71
  updating to the current MOLE schema  31
Defense Solutions SDK
  migrating your Military Analyst and MOLE applications to the new Defense Solutions library  
    97–99
  overview  7–8
  what you get with  93
developer documentation
developer help  94
Direction Visibility  17, 31, 32, 34, 36
DirectVis. See Direction Visibility
documentation conventions  2
documentation set, described  6
download page  8
dragon’s teeth  17
E
esriDefenseSolutions.olb  15
Extract RPF Catalog Items  17
feature class types, MOLE 57
force element 17
  feature class type
    and MOLE Layer Properties dialog boxes 57
    creating a MOLE feature class 39
    updating MOLE data 35–36
  feature class type, updating MOLE data 36
in ArcGlobe 30
in MOLE geoprocessing tools 45
force unit. See force element
forums
    Military Analyst and MOLE 7

geodatabase
  as compared with shapefile 37
  overview of creating for Military Analyst and MOLE 38–39
geoprocessing
  getting started with 42
    tools described (Military Analyst) 44
  getting help 7
Graphic Height 73, 81
graphic layer, MOLE 57
group layer, MOLE 57
GUID 24

help system, how to access 6
Hide Selection, Military Analyst 15

installing ArcGlobe 25
installing defense solutions 22–26
ISymbol approach to developing with MOLE. See symbol-based approach in this guide

Java 94, 95
knowledge base article 7, 9
Layer Properties dialog box
  MOLE 57
Layer Properties dialog box, MOLE 75, 81
Linear Line of Sight
  new geoprocessing tool 16
Linux. See cross platform
LLOS. See Linear Line of Sight
managed setups 22, 24
Match Selection, Military Analyst 15
migrating. See also updating
  migrating your Military Analyst and MOLE applications to the Defense Solutions library 97
Military Analyst overview 3
military symbols
  creating with the MOLE Symbol Editor 55
model building. See geoprocessing
moleCore database 18
MOLE graphic layer 57
MOLE layer 57
MOLE overview 4
MOLE schema. See schema
MOLE Symbol Editor
  areas described (illustration) 55
  fields described 56
network installations 24
O

OILSTOCK

as described in Military Analyst overview 4
Options dialog box
illustrated (Military Analyst) 48
overview of Defense Solutions applications 3–5

P

pre-installation checklist 22
privileges. See administrator privileges

R

Renderers tab 79
Restore Selection, Military Analyst 15

S

sample data

MOLE 5
samples

developer samples 97
geoprocessing toolset for Military Analyst 17
schema
changes for each version listed (MOLE) 32
updating methods 34
SDK. See Defense Solutions SDK
set size. See Graphic Height (MOLE)
setting up

Military Analyst 27
shapefile

and MOLE with ArcSDE 30
as compared to geodatabase 37
in Linear Line of Sight geoprocessing tool (Military
Analyst) 44
in MOLE sample data 5
in the Import OILSTOCK Overlay geoprocessing
tool (Military Analyst) 45

setting up MOLE using 31
Tracking Analyst and MOLE 87
using with MOLE and ArcCatalog 37
using with MOLE geoprocessing tools 45
using with the Convert VPF Features tool (Military
Analyst) 52
with the Highest/Lowest Point tool (Military Ana-
lyst) 51

silent install

Military Analyst and MOLE 24

starting

Military Analyst 27
MOLE 28
symbol-based approach
overview 18
Symbol Height, MOLE 17
system requirements 20–26
additional for developers 93
genral 20
Military Analyst specific 21
MOLE-specific 21

T

table of contents

Defense Solutions in ArcGIS Desktop Help 6
for this guide iii
tactical symbol. See force element
technical support 7
tetrahedrons 17
TOC. See table of contents
toolbar

Military Analyst, adding 27
Military Analyst in ArcGlobe, buttons illustrated 47
Military Analyst in ArcMap, buttons illustrated 47
MOLE, adding 29
MOLE in ArcGlobe, buttons illustrated 54
MOLE in ArcMap, buttons illustrated 54
toolboxes
adding 42
toolset
  Link Tools 16
  Samples 17
  Terrain Analysis 16
tracking 4, 87

U
uninstalling 24
UNIX. See cross platform
updating. See also migrating
  MOLE data 31
  MOLE schema methods 34

V
Vista 15
Visual C++ 95

W
Web help for Military Analyst, Grid Manager, and
  MOLE 6
WebLinks, Military Analyst 16
Windows 2
wireframe symbology table 53